Harmonic Number

                              Harmonic Number
 

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:


In this problem, you are given n, you have to find Hn.
Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n ≤ 108).
Output
For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.
Sample Input
12
1
2
3
4
5
6
7
8
9
90000000
99999999
100000000
Sample Output
Case 1: 1
Case 2: 1.5
Case 3: 1.8333333333
Case 4: 2.0833333333
Case 5: 2.2833333333
Case 6: 2.450
Case 7: 2.5928571429
Case 8: 2.7178571429
Case 9: 2.8289682540
Case 10: 18.8925358988
Case 11: 18.9978964039
Case 12: 18.9978964139
题意:求f(n)=1/1+1/2+1/3+1/4…1/n   (1 ≤ n ≤ 108).,精确到10-8  
知识点:
     调和级数(即f(n))至今没有一个完全正确的公式,但欧拉给出过一个近似公式:(n很大时)
      f(n)≈ln(n)+C+1/2*n    
      欧拉常数值:C≈0.57721566490153286060651209
      c++ math库中,log即为ln。
题解:
公式:f(n)=ln(n)+C+1/(2*n);
n很小时直接求,此时公式不是很准。
下面上代码:
 

#include<stdio.h>
#include <math.h>
using namespace std;
const double r=0.57721566490153286060651209;     //欧拉常数


double a[10000];


int main()
{
    int i;
    a[1]=1;
    for (int i=2;i<10000;i++)
    {
        a[i]=a[i-1]+1.0/i;
    }
    int m;
    scanf("%d",&m);
    for (i=1;i<=m;i++)
    {
        int n;
        scanf("%d",&n);
        if (n<10000)
        {
            printf("Case %d: %.10lf\n",i,a[n]);
        }
        else
        {
            double a=log(n)+r+1.0/(2*n);
            printf("Case %d: %.10lf\n",i,a);
        }
    }
    return 0;
}


如果记不住的话,打表也可以过,

10e8全打表必定MLE,而每40个数记录一个结果,即分别记录1/40,1/80,1/120,...,1/10e8,这样对于输入的每个n,最多只需执行39次运算,大大节省了时间,空间上也够了。


上代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>

using namespace std;

const int maxn = 2500001;
double a[maxn] = {0.0, 1.0};

int main()
{
    int t, n, ca = 1;
    double s = 1.0;
    for(int i = 2; i < 100000001; i++)
    {
        s += (1.0 / i);
        if(i % 40 == 0) a[i/40] = s;
    }
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        int x = n / 40;
        s = a[x];
        for(int i = 40 * x + 1; i <= n; i++) s += (1.0 / i);
        printf("Case %d: %.10lf\n", ca++, s);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值