hpu暑假训练 B - Ignatius and the Princess IV 【sort】

B - Ignatius and the Princess IV

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?


Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
Output
For each test case, you have to output only one line which contains the special number you have found.
Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
Sample Output
3
5
1


解析:
    题目大意就是给你n个数(n是奇数),然你找出其中出现次数大于等于(n+1)/2的数字。


    我们可以先对数列从小到大排序,从第一个数字开始查询并计数,如果满足题意直接输出,否则就继续判断下一个数字。
    因为n比较大,建议数组定义在main函数外面。ps:(本题最优解就是排序之后直接输出第(n+1)/2个数)


程序如下:

#include<cstdio>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)
{
	return a<b;
}
int a[1000000];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i,j;
		for(i=0;i<n;i++)
		   scanf("%d",&a[i]);
		sort(a,a+n,cmp);
		int ant=a[0],ans=0;
		for(i=0;i<n;i++)
		{
			if(a[i]==ant)
			{
				ans++;
				if(ans>=(n+1)/2)
				{
					printf("%d\n",ant);
				    break;
				}  
			}
			else
			{
				ant=a[i];
			}
		}
	}
	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值