【PAT1039】 Course List for Student (25) Hash表

1039. Course List for Student (25)

时间限制
200 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
题意:

给出选修每门课程的所有学生列表,求出某个学生的所有选修课程。

分析:

最简单的思路是对课程建立结构体数组:

 
 
 
 
struct Student{
 
 
char name[5];
 
 
};
 
 
 
 
struct Course{
 
 
int id;
 
 
int num;
 
 
Student* s;
 
 
};
 
 

将Course结构体数组根据id,从小到大排序;查询时,遍历此数组,对于姓名从小到大的排列方式采用二分法查找。

代码如下:

#include <iostream>
#include <fstream>
#include <algorithm>
#include <vector>
#include <cstring>
#include <stdio.h>
using namespace std;

//此代码使用前,需删除下面两行+后面的system("PAUSE")
ifstream fin("in.txt");
#define cin fin

struct Student{
	char name[5];
};

struct Course{
	int id;
	int num;
	Student* s;
};

bool cmp(const Course& aa,const Course& bb){
	return aa.id < bb.id;
}

bool BinarySearch(char query[],const Course& c){
	int left = 0;
	int right = c.num-1;
	int mid,res;
	while(left <= right){
		mid = (left+right)/2;
		res = strcmp(c.s[mid].name,query);
		if(res == 0){		
			return true;
		}else if(res > 0){	//比query大
			right = mid - 1;
		}else{
			left = mid + 1;
		}
	}
	return false;
}

int main()
{
	int n,k;
	scanf("%d %d",&n,&k);
	//cin>>n>>k;
	Course* c = new Course[k];
	int courseID,num;
	int i,j,z;
	for(i=0;i<k;i++){
		scanf("%d %d",&c[i].id,&c[i].num);
		//cin>>c[i].id>>c[i].num;
		c[i].s = new Student[c[i].num];
		for(j=0;j<c[i].num;j++){
			scanf("%s",c[i].s[j].name);
			//cin>>c[i].s[j].name;
		}
	}
	sort(c,c+k,cmp);

	vector<int> idVec;
	char queryName[5];
	for(i=0;i<n;i++){
		scanf("%s",queryName);
		//cin>>queryName;
		idVec.clear();
		for(j=0;j<k;j++){
			if(BinarySearch(queryName,c[j])){
				idVec.push_back(j+1);	
			}
		}
		int size = idVec.size();
		printf("%s %d",queryName,size);
		//cout<<queryName<<' '<<size;
		for(z=0;z<size-1;z++){
			printf(" %d",idVec[z]);
			//cout<<' '<<idVec[z];
		}
		if(size>0){
			printf(" %d",idVec[size-1]);
			//cout<<' '<<idVec[size-1];
		}
		printf("\n");
		//cout<<endl;
	}

	system("PAUSE");
	return 0;
}
但最后一个Case运行超时。


优化思路:

①char name[5] 字符数组的比较效率低于整型,将name经过hash转换为一个整型。

②以整型name建立hash表,vector<vector<int>vec(MAX_STU+1); 存储该学生姓名所选修的所有课程;输出时先进行排序。

AC代码如下:

#include <iostream>
#include <fstream>
#include <algorithm>
#include <vector>
#include <cstring>
#include <stdio.h>
using namespace std;

//此代码使用前,需删除下面两行+后面的system("PAUSE")
ifstream fin("in.txt");
#define cin fin

const int MAX_STU = 26*26*26*10;

int hashName(const char * name){
	return (name[0]-'A')*26*26*10+(name[1]-'A')*26*10+(name[2]-'A')*10+(name[3]-'0');
}

int main()
{
	int n,k;
	scanf("%d %d",&n,&k);
	//cin>>n>>k;
	int i,j,z;
	vector< vector<int> > vec(MAX_STU+1);
	int id,num;
	char name[5];

	for(i=0;i<k;i++){
		//cin>>id>>num;
		scanf("%d %d",&id,&num);
		for(j=0;j<num;j++){
			//cin>>name;
			scanf("%s",name);
			vec[hashName(name)].push_back(id);
		}
	}
	vector<int> tt;
	char queryName[5];
	for(i=0;i<n;i++){
		scanf("%s",queryName);
		//cin>>queryName;
		tt = vec[hashName(queryName)];
		sort(tt.begin(),tt.end());

		int size = tt.size();
		printf("%s %d",queryName,size);
		//cout<<queryName<<' '<<size;
		for(z=0;z<size-1;z++){
			printf(" %d",tt[z]);
			//cout<<' '<<tt[z];
		}
		if(size>0){
			printf(" %d",tt[size-1]);
			//cout<<' '<<tt[size-1];
		}
		printf("\n");
		//cout<<endl;
	}

	system("PAUSE");
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值