POJ 1328 Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28083 Accepted: 6152

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source


思路:对坐标点按x值从小到大排序,从最左边的点开始,求出雷达的放置区间,和下一个点的区间求交集。如果没有交集,则需要增加一个雷达,以此进行到最后一个点。

代码如下:
#include <iostream>
#include <math.h>
#include <algorithm>
using namespace std;

#define LEN 1000
struct Point{
	int x;
	int y;
}*point;

bool cmp(Point a,Point b)
{
	return a.x < b.x;
}

int myCmp(const void* a,const void* b)
{
	const Point *aa=(Point *)a;
	const Point *bb=(Point *)b;
	return aa->x > bb->x;
}

int main()
{
	freopen("in.txt","r",stdin);
	int n,d;
	int i,count;
	int ase=0;
	double minx,maxx,minx2,maxx2,value,value2;
	point = (Point*)malloc(sizeof(Point)*LEN);
	while(1)
	{
		cin>>n>>d;
		if(n==0 && d==0)break;
		ase ++;
		for(i=0;i<n;i++)
		{
			cin>>point[i].x>>point[i].y;
		}
		sort(point,point+n,cmp);
		//qsort(point,n,sizeof(Point),myCmp);
		//for(i=0;i<n;i++){cout<<point[i].x<<"  "<<point[i].y<<endl;}

		cin.ignore();  //可以省略
		if(n==0){cout<<"Case "<<ase<<": "<<0<<endl;continue;}
		minx=point[0].x;
		maxx=point[n-1].x;
		count=1;
		for(i=0;i<n;i++)
		{
			if(point[i].y > d){count=-1;break;}
			value = d*d-point[i].y*point[i].y;
			value2 = sqrt(value);
			minx2 = point[i].x-value2;
			maxx2 = point[i].x+value2;
			if(minx2 > maxx )//不相交  minx2 - maxx >10e-7 这里不考虑也能AC
			{
				//minx = minx2;   //左端 不需要
				maxx = maxx2;
				count++;
			}
			else 
			{
				//if(minx2>minx)minx=minx2;     
				if(maxx>maxx2)maxx=maxx2;
			}

		}
		cout<<"Case "<<ase<<": "<<count<<endl;
		//cout<<"----------------------------"<<endl;
	}
	return 0;
}

使用sort函数可以AC,但使用qsort会WA。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值