Ubiquitous Religions POJ2524

Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 15791 Accepted: 7606

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

题意:

一个学校的学生信仰宗教的最大种类数。已知学生总数及同一信仰的两个学生号。

分析:

并查集的简单应用,将同一信仰的两个学生合并。求得共有多少个分组,未提及的学生自成一组,算得最大种类数。

源代码如下:

#include <iostream>
using namespace std;

int father[50001],rank[50001];

void Init(int n)
{
	int i;
	for(i=1;i<=n;i++)
	{
		father[i]=i;
		rank[i]=1;
	}
}

int Find_Set(int x)
{
	if(x!=father[x])
		father[x]=Find_Set(father[x]);
	return father[x];
}

void Union_Set(int x,int y)
{
	x=Find_Set(x);
	y=Find_Set(y);
	if(x==y)return;
	if(rank[x]>=rank[y])
	{
		father[y]=x;
		rank[x]+=rank[y];
	}else
	{
		father[x]=y;
		rank[y]+=rank[x];
	}
}

int main()
{
	freopen("in.txt","r",stdin);
	int n,m;
	int i,x,y,c;
	int num=1;
	while(1)
	{
		cin>>n>>m;
		if(!n && !m)break;
		Init(n);
		for(i=0;i<m;i++)
		{
			cin>>x>>y;
			Union_Set(x,y);
		}
		c=0;
		for(i=1;i<=n;i++)
		{
			if(i==father[i])c++;
		}
		cout<<"Case "<<num<<": "<<c<<endl;
		num++;
	}
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值