HDU1097A hard puzzle

[align=center]A hard puzzle[/align]
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13911 Accepted Submission(s): 4872


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.



Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)



Output
For each test case, you should output the a^b's last digit number.



Sample Input
7 66
8 800


Sample Output
9
6


Author
eddy

题意:求a^b结果的个位数是多少

#include <iostream>
using namespace std;
/*
分析:当a的个位是0 1 2 3 4 5 6 7 8 9时,只会出现一下循环,例如个位是2 那以后个位只会在2 4 8 6之间变动
0
1
2 4 8 6
3 9 7 1
4 6
5
6
7 9 3 1
8 4 2 6
9 1
*/
int cns[10][4] = {{0},{1}, {6, 2, 4, 8},{1, 3, 9, 7},{6, 4}, {5}, {6}, {1, 7, 9, 3}, {6, 8, 4, 2}, {1, 9}};
int main()
{
int a, b, digit, cnt;
while(cin>>a>>b)
{
digit = a % 10;
switch(digit)
{
case 0:
case 1:
case 5:
case 6:
cout<<digit<<endl;
continue;
break;
case 2:
case 3:
case 7:
case 8:
cnt = b % 4;
break;
case 4:
case 9:
cnt = b % 2;
break;
}
cout<<cns[digit][cnt]<<endl;
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值