Knight Moves——双向宽搜初始值的赋法

下载LOFTER我的照片书 |
Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
这里写图片描述

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, …, l-1}*{0, …, l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1
Sample Output

5
28
0
双向宽搜的时候,初始值赋成1,这样的话vis就可以!=0,最后再减掉2,因为如果起点到终点的最短路就是终点
本身,别的赋法很容易出现错误。

#include<iostream>
#include<stdio.h>
#include<queue>
#include<cstring>
using namespace std;
struct node
{
    int x,y,step,id;
}sta,fin;
int xmov[]={-2,-1,1,2,2,1,-1,-2};
int ymov[]={1,2,2,1,-1,-2,-2,-1};
int vis[2][305][305];
int l;
int bfs()
{
    queue<node>Q;
    vis[sta.id][sta.x][sta.y]=1;
    vis[fin.id][fin.x][fin.y]=1;
    Q.push(sta);
    Q.push(fin);
    while(!Q.empty())
    {
        node v,ne;
        v=Q.front();
        Q.pop();
        for(int i=0;i<8;i++)
        {
            ne.x=v.x+xmov[i];
            ne.y=v.y+ymov[i];
            if(ne.x<0||ne.x>=l||ne.y<0||ne.y>=l||vis[v.id][ne.x][ne.y])
                continue;
            ne.id=v.id;
            ne.step=v.step+1;
            if(vis[ne.id^1][ne.x][ne.y]!=0)
                return ne.step+vis[ne.id^1][ne.x][ne.y];
            vis[ne.id][ne.x][ne.y]=ne.step;
            Q.push(ne);
        }
    }
    return -1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%d",&l);
        scanf("%d%d",&sta.x,&sta.y);
        sta.step=1;
        sta.id=1;
        scanf("%d%d",&fin.x,&fin.y);
        fin.step=1;
        fin.id=0;
        if(sta.x==fin.x&&sta.y==fin.y)
            printf("0\n");
        else
            printf("%d\n",bfs()-2);
    }
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值