JiLi Number UVALive - 7678 —— dp?其实是打表

Driver Ji likes the digit “1”. He has an accumulator which shows the sum of input number. He lists all
of positive number no more than N and starts counting from one, two, three . . . Every time he counts
a number he will add the number of digit “1” in this number to accumulator at the same time. The
amazing thing happens! At some times, when he finishes counting a number X, the number which on
the accumulator is X exactly, he will regard X as “JiLi Number” which means lucky number. Now he
wants to know the number of “JiLi Numbers” and the biggest “JiLi Number” no more than N.
Input
There are several test cases and the each test case is a line contains an positive integer N, (1 < N ≤
10100)
Output
For each test case, output two integers which donates the number of “JiLi Numbers” and the biggest
“JiLi Number”.
Sample Input
1
100000000000
Sample Output
1 1
83 1111111110

题意:

从1到n枚举,计数器加上没聚到的数中1的个数,举个例子:1的时候是1,2的时候是1,10的时候是2,11的时候是4.
如果有一个数,枚举到它的时候计数器正好也是那个数,那么num就+1,这个数就叫做幸运数。问你到n的时候num和最大的幸运数。

题解:

没怎么写过打表,都是队里另外一个人负责的= =!!,一开始看到这个题目就以为是数位dp,但是后面的那个数就没法求了,想来想去还是别人提醒我达标是否可以找到规律。最后发现只有83个数。。。

#include<bits/stdc++.h>
using namespace std;
#define ll long long
ll ans[100]={
1,
199981,
199982,
199983,
199984,
199985,
199986,
199987,
199988,
199989,
199990,
200000,
200001,
1599981,
1599982,
1599983,
1599984,
1599985,
1599986,
1599987,
1599988,
1599989,
1599990,
2600000,
2600001,
13199998,
35000000,
35000001,
35199981,
35199982,
35199983,
35199984,
35199985,
35199986,
35199987,
35199988,
35199989,
35199990,
35200000,
35200001,
117463825,
500000000,
500000001,
500199981,
500199982,
500199983,
500199984,
500199985,
500199986,
500199987,
500199988,
500199989,
500199990,
500200000,
500200001,
501599981,
501599982,
501599983,
501599984,
501599985,
501599986,
501599987,
501599988,
501599989,
501599990,
502600000,
502600001,
513199998,
535000000,
535000001,
535199981,
535199982,
535199983,
535199984,
535199985,
535199986,
535199987,
535199988,
535199989,
535199990,
535200000,
535200001,
1111111110
};
int main()
{
    ll n;
    while(~scanf("%lld",&n))
    {
        int pos=upper_bound(ans,ans+83,n)-ans;
        printf("%d %lld\n",pos,ans[pos-1]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值