01分数规划问题,poj2976

  最近遇到了一类问题在翻阅大神博客后方知是01分数规划问题

感谢大神博客:http://blog.csdn.net/hhaile/article/details/8883652

解题思路:将公式化简F(L)=sigma(a[i]*x[i])-L*sigma(b[i]*x[i]),当确定一个L时,如果还有符合条件的L并且比原来的大,此时f》0,由于结果是1--100之内的数,所以最多需要找100次

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

Source

ac代码:

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;
int n,k;
int a[1002],b[1002];
double c[1002];
bool wo(double mid)
{
    for(int i=0;i<n;i++)
    c[i]=(double)a[i]-(double)b[i]*mid;
    sort(c,c+n);
    double sum=0;
    for(int i=k;i<n;i++)
    sum+=c[i];
    return sum>0;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        if(n==0&&k==0)
        break;
        for(int i=0;i<n;i++)
        scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
        scanf("%d",&b[i]);
        double l=0,r=1,mid;
        for(int i=0;i<100;i++)
        {
          mid=(l+r)/2;
          if(wo(mid))
          l=mid;
          else
          r=mid;
        }
        printf("%d\n",(int)(100*mid+0.5));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值