hdu 4920 矩阵相乘


Given two matrices A and B of size n×n, find the product of them.

bobo hates big integers. So you are only asked to find the result modulo 3. Input
The input consists of several tests. For each tests:

The first line contains n (1≤n≤800). Each of the following n lines contain n integers -- the description of the matrix A. The j-th integer in the i-th line equals A ij. The next n lines describe the matrix B in similar format (0≤A ij,B ij≤10 9).
Output
For each tests:

Print n lines. Each of them contain n integers -- the matrix A×B in similar format.
Sample Input
1
0
1
2
0 1
2 3
4 5
6 7
Sample Output
0
0 1
2 1
 
 
       给你两个矩阵,然后让你计算矩阵的乘积
       直接乘就可以了,有0的话直接跳过不要乘,还有不要把取余运算放在三重循环中(会超时)
ac代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
int a[1000][1000],b[1000][1000],c[1000][1000];
int main()
{
    int n;
    while(scanf("%d",&n)!=-1)
    {
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                scanf("%d",&a[i][j]);
                a[i][j]=a[i][j]%3;
                c[i][j]=0;
            }
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                scanf("%d",&b[i][j]);
                b[i][j]=b[i][j]%3;
            }
        for(int i=0; i<n; i++)
            for(int k=0; k<n; k++)
                if(a[i][k])
                    for(int j=0; j<n; j++)
                        c[i][j]=(c[i][j]+a[i][k]*b[k][j])%3;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n-1; j++)
                printf("%d ",c[i][j]);
            printf("%d\n",c[i][n-1]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值