hdu5971 Wrestling Match

Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into "good player" and "bad player".
Input
Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known "good players" and the number of known "bad players".In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a "good player" number.The last line contains Y different numbers.Each number represents a known "bad player" number.Data guarantees there will not be a player number is a good player and also a bad player.
Output
If all the people can be divided into "good players" and "bad players”, output "YES", otherwise output "NO".
Sample Input
5 4 0 0
1 3
1 4
3 5
4 5
5 4 1 0
1 3
1 4
3 5
4 5
2
Sample Output
NO

YES

题意:

ac代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
using namespace std;
int vis[1005];
vector<int> ve[1005];
int dg[1005];
int bd[1005];
int dfs(int p,int q)
{
    vis[p]=q;
    int t;
    if(q==2)t=1;
    else t=2;
    for(int i=0;i<ve[p].size();i++)
    {
        if(vis[ve[p][i]]==q)
        return 0;
        if(vis[ve[p][i]]==0&&dfs(ve[p][i],t)==0)
        return 0;
    }
    return 1;
}
int main()
{
    int n,m,x,y,a,b;
    while(cin>>x>>y>>n>>m)
    {
        int flag=0;
        for(int i=0;i<x;i++)
        ve[i].clear();
        memset(vis,-1,sizeof(vis));
        for(int i=1;i<=y;i++)
        {
            scanf("%d%d",&a,&b);
            vis[a]=0;vis[b]=0;
            ve[a].push_back(b);
            ve[b].push_back(a);
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);
            vis[a]=1;
            for(int j=0;j<ve[a].size();j++)
            {
                if(vis[ve[a][j]]==1)
                {
                    flag=1;
                    break;
                }
                else
                vis[ve[a][j]]=2;
            }
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d",&a);
            vis[a]=2;
            for(int j=0;j<ve[a].size();j++)
            {
                if(vis[ve[a][j]]==2)
                {
                    flag=1;
                    break;
                }
                else
                vis[ve[a][j]]=1;
            }
        }
        for(int i=1;i<=x;i++)
        {
            if(vis[i]==1)
            {
              if(dfs(i,1)==0)
              {
                  flag=1;
                  break;
              }
            }
            if(vis[i]==2)
            {
                if(dfs(i,2)==0)
                {
                    flag=1;
                    break;
                }
            }
            if(vis[i]==0)
            {
                if(dfs(i,1)==0&&dfs(i,2)==0)
                {
                    flag=1;
                    break;
                }
            }
        }
        for(int i=1;i<=x;i++)
        {
            if(vis[i]==-1)
            {
                flag=1;break;
            }
        }
        if(flag==1)
        cout<<"NO"<<endl;
        else
        cout<<"YES"<<endl;
    }
    return 0;
}

    
    

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值