Fang Fang 思维题

Fang Fang says she wants to be remembered.
I promise her. We define the sequence F  F of strings.
F 0  = f",  F0 = ‘‘f",
F 1  = ff",  F1 = ‘‘ff",
F 2  = cff",  F2 = ‘‘cff",
F n  = F n1  + f", for n > 2  Fn = Fn−1 + ‘‘f", for n > 2
Write down a serenade as a lowercase string S  S in a circle, in a loop that never ends.
Spell the serenade using the minimum number of strings in F  F, or nothing could be done but put her away in cold wilderness.
Input
An positive integer T  T, indicating there are T  T test cases.
Following are T  T lines, each line contains an string S  S as introduced above.
The total length of strings for all test cases would not be larger than 10 6   106.
Output
The output contains exactly T  T lines.
For each test case, if one can not spell the serenade by using the strings in F  F, output 1  −1. Otherwise, output the minimum number of strings in F  F to split S  S according to aforementioned rules. Repetitive strings should be counted repeatedly.
Sample Input
8
ffcfffcffcff
cffcfff
cffcff
cffcf
ffffcffcfff
cffcfffcffffcfffff
cff
cffc
Sample Output
Case #1: 3
Case #2: 2
Case #3: 2
Case #4: -1
Case #5: 2
Case #6: 4
Case #7: 1
Case #8: -1

        
  
Hint
Shift the string in the first test case, we will get the string "cffffcfffcff"
and it can be split into "cffff", "cfff" and "cff".

简单思维题,只需要统计c的个数,然后就是考虑不可能的情况

1.存在c但他后边的两个字符不是ff(还要注意是循环串)

2.存在除c和f之外的其他元素(最大的坑点)

如果字符串全是f的话就按照奇偶计算最小数就好了

ac代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
char a[1000005];
int main()
{
    int t;
    cin>>t;
    int p=0;
    getchar();
    while(t--)
    {
        p++;
        gets(a);
        int len=strlen(a);
        int sum=0;
        int flag=0;
        for(int i=0; i<len; i++)
        {
            if(a[i]!='c'&&a[i]!='f')
            flag=1;
            if(a[i]=='c')
            {
                sum++;
                int k=0;
                for(int j=i+1;; j++)
                {
                    int l;
                    if(j>len-1)
                        l=j-len;
                    else
                        l=j;
                    k++;
                    if(a[l]=='c')
                    {
                        flag=1;
                        break;
                    }
                    if(k==2)
                        break;
                }
            }
            if(flag==1)
            break;
        }
        if(sum==0)
        {
            if(len%2==0)
            sum=len/2;
            else
            sum=len/2+1;
        }
        printf("Case #%d: ",p);
        if(flag==1)
            printf("-1\n");
        else
            printf("%d\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值