hdu 4405 概率dp

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N. 

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid. 

Please help Hzz calculate the expected dice throwing times to finish the game. 
Input
There are multiple test cases. 
Each test case contains several lines. 
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000). 
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).   
The input end with N=0, M=0. 
Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point. 
Sample Input
2 0
8 3
2 4
4 5
7 8
0 0
Sample Output
1.1667

2.3441

题意:玩飞行棋,从0走到n,每次掷骰子,掷到几走几步,还有一些直接到达的点

如果题中给出(a,b)数对,那么当你走到a时可以直接跳到b,问知多少次骰子可以到达n或者超过n的期望

思路:

直接倒着dp就可以了,如果i节点可以直接跳到某个节点j那么dp[i]=dp[j],否则就是枚举骰子面k

dp[i]+=dp[i+(1~6)]+1;

ac代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <vector>
using namespace std;
const int maxn=1e5+5;
int vis[maxn];
double dp[maxn];
int main()
{
    int n,m;
    while(cin>>n>>m&&(n+m))
    {
        int x,y;
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            vis[x]=y;
        }
        memset(dp,0,sizeof(dp));
        for(int i=n-1;i>=0;i--)
        {
            if(vis[i]==0)
            {
                for(int j=1;j<=6;j++)
                dp[i]+=dp[j+i]/6;
                dp[i]++;
            }
            else
            dp[i]=dp[vis[i]];
        }
        printf("%.4lf\n",dp[0]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值