P2926 [USACO08DEC] Patting Heads S【数学】

[USACO08DEC] Patting Heads S

题面翻译

今天是贝茜的生日,为了庆祝自己的生日,贝茜邀你来玩一个游戏。

贝茜让 N N N ( 1 ≤ N ≤ 1 0 5 1\leq N\leq 10^5 1N105) 头奶牛坐成一个圈。除了 1 1 1 号与 N N N 号奶牛外, i i i 号奶牛与 i − 1 i-1 i1 号和 i + 1 i+1 i+1 号奶牛相邻。 N N N 号奶牛与 1 1 1 号奶牛相邻。农夫约翰用很多纸条装满了一个桶,每一张包含了一个不一定是独一无二的 1 1 1 1 0 6 10^6 106 的数字。

接着每一头奶牛 i i i 从桶中取出一张纸条 A i A_i Ai。每头奶牛轮流走上一圈,同时拍打所有手上数字能整除在自己纸条上的数字的牛的头,然后坐回到原来的位置。牛们希望你帮助他们确定,每一头奶牛需要拍打的牛的数量。

题目描述

It’s Bessie’s birthday and time for party games! Bessie has instructed the N (1 <= N <= 100,000) cows conveniently numbered 1…N to sit in a circle (so that cow i [except at the ends] sits next to cows i-1 and i+1; cow N sits next to cow 1). Meanwhile, Farmer John fills a barrel with one billion slips of paper, each containing some integer in the range 1…1,000,000.

Each cow i then draws a number A_i (1 <= A_i <= 1,000,000) (which is not necessarily unique, of course) from the giant barrel. Taking turns, each cow i then takes a walk around the circle and pats the heads of all other cows j such that her number A_i is exactly

divisible by cow j’s number A_j; she then sits again back in her original position.

The cows would like you to help them determine, for each cow, the number of other cows she should pat.

输入格式

* Line 1: A single integer: N

* Lines 2…N+1: Line i+1 contains a single integer: A_i

输出格式

* Lines 1…N: On line i, print a single integer that is the number of other cows patted by cow i.

样例 #1

样例输入 #1

5 
2 
1 
2 
3 
4

样例输出 #1

2 
0 
2 
1 
3

提示

The 5 cows are given the numbers 2, 1, 2, 3, and 4, respectively.

The first cow pats the second and third cows; the second cows pats no cows; etc.

问题链接: P2926 [USACO08DEC] Patting Heads S
问题分析: 数学问题,不解释。
参考链接: (略)
题记: (略)

AC的C++语言程序如下:

/* P2926 [USACO08DEC] Patting Heads S */

#include <iostream>

using namespace std;

const int N = 100000;
const int M = 1000000;
int a[N + 1];
int b[M + 1] = {0}, ans[M + 1] = {0};

int main()
{
    int n, maxa = 0;
    cin >> n;
    for (int i = 1; i <= n; i++) {
        cin >> a[i];
        b[a[i]]++;
        if (a[i] > maxa) maxa = a[i];
    }
    for (int i = 1; i <= maxa; i++)
        if (b[i])
            for (int j = 1; j * i <= maxa; j++)
                ans[j * i] += b[i];
    for (int i = 1; i <= n; i++)
        cout << ans[a[i]] - 1 << endl;
    return 0;
}
  • 27
    点赞
  • 13
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值