UVA232 UVALive5171 POJ1888 Crossword Answers【谜题】

509 篇文章 8 订阅
3 篇文章 0 订阅

 

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 1343 Accepted: 569

 

Description

A crossword puzzle consists of a rectangular grid of black and white squares and two lists of definitions (or descriptions). 

One list of definitions is for ``words" to be written left to right across white squares in the rows and the other list is for words to be written down white squares in the columns. (A word is a sequence of alphabetic characters.) 

To solve a crossword puzzle, one writes the words corresponding to the definitions on the white squares of the grid. 

The definitions correspond to the rectangular grid by means of sequential integers on ``eligible" white squares. White squares with black squares immediately to the left or above them are ``eligible." White squares with no squares either immediately to the left or above are also ``eligible." No other squares are numbered. All of the squares on the first row are numbered. 

The numbering starts with 1 and continues consecutively across white squares of the first row, then across the eligible white squares of the second row, then across the eligible white squares of the third row and so on across all of the rest of the rows of the puzzle. The picture below illustrates a rectangular crossword puzzle grid with appropriate numbering. 


An "across" word for a definition is written on a sequence of white squares in a row starting on a numbered square that does not follow another white square in the same row. The sequence of white squares for that word goes across the row of the numbered square, ending immediately before the next black square in the row or in the rightmost square of the row. 

A "down" word for a definition is written on a sequence of white squares in a column starting on a numbered square that does not follow another white square in the same column. The sequence of white squares for that word goes down the column of the numbered square, ending immediately before the next black square in the column or in the bottom square of the column. Every white square in a correctly solved puzzle contains a letter. 

You must write a program that takes several solved crossword puzzles as input and outputs the lists of across and down words which constitute the solutions. 
 

Input

Each puzzle solution in the input starts with a line containing two integers r and c (1 <= r <= 10 and 1 <= c <= 10), where r (the first number) is the number of rows in the puzzle and c (the second number) is the number of columns. The r rows of input which follow each contain c characters (excluding the end-of-line) which describe the solution. Each of those c characters is an alphabetic character which is part of a word or the character "*", which indicates a black square. The end of input is indicated by a line consisting of the single number 0.

Output

Output for each puzzle consists of an identifier for the puzzle (puzzle #1, puzzle #2, etc.) and the list of across words followed by the list of down words. Words in each list must be output one-per-line in increasing order of the number of their corresponding definitions. The heading for the list of across words is "Across". The heading for the list of down words is "Down". In the case where the lists are empty (all squares in the grid are black), the Across and Down headings should still appear.

Sample Input

2 2
AT
*O
6 7
AIM*DEN
*ME*ONE
UPON*TO
SO*ERIN
*SA*OR*
IES*DEA
0

Sample Output

puzzle #1:
Across
  1.AT
  3.O
Down
  1.A
  2.TO

puzzle #2:
Across
  1.AIM
  4.DEN
  7.ME
  8.ONE
  9.UPON
 11.TO
 12.SO
 13.ERIN
 15.SA
 17.OR
 18.IES
 19.DEA
Down
  1.A
  2.IMPOSE
  3.MEO
  4.DO
  5.ENTIRE
  6.NEON
  9.US
 10.NE
 14.ROD
 16.AS
 18.I
 20.A

Source

 

 

 

World Finals >> 1994 - Phoenix

 

问题链接UVA232 UVALive5171 POJ1888 Crossword Answers

问题简述:(略)

问题分析

  典型单词谜题中,计算单词个数问题。

  给网格扩充了四个方向的边界。这样可以简化程序逻辑,使得边缘格的处理逻辑与中间格的处理逻辑相同。使得判断网格是否为单词的开始网格条件统一;同时,计算行单词和列单词的逻辑也变得简单。

  另外一点就是要明确单纯开始网格的条件,以及如何计算单词的序号(序号增加的条件)。

程序说明

  程序中,将边界设置为“*”,程序逻辑比较简洁。

 

AC的C语言程序如下:

 

/* UVA232 UVALive5171 POJ1888 Crossword Answers */

#include <stdio.h>

#define MAXN 10

char grid[MAXN+2][MAXN+2];

/* 输出行单词 */
void rowoutput(int no, int row, int col)
{
    printf("%3d.", no);
    while(grid[row][col] != '*')
        putchar(grid[row][col++]);
    putchar('\n');
}

/* 输出列单词 */
void coloutput(int no, int row, int col)
{
    printf("%3d.", no);
    while(grid[row][col] != '*')
        putchar(grid[row++][col]);
    putchar('\n');
}

int main(void)
{
    int r, c, caseno=0, wcount, i, j;

    while(scanf("%d", &r) != EOF && r != 0) {
        /* 已经读入行,继续读入列 */
        scanf("%d", &c);
        getchar();

        /* 读入网格 */
        for(i=1; i<=r; i++) {
            for(j=1; j<=c; j++)
                grid[i][j] = getchar();
            getchar();      /* '\n' */
        }

        // 设置边界
        for(i=0; i<r+2; i++) {
            grid[i][0] = '*';
            grid[i][c+1] = '*';
        }
        for(i=0; i<c+2; i++) {
            grid[0][i] = '*';
            grid[r+1][i] = '*';
        }

        /* 计算并且输出结果 */
        if(++caseno > 1)
            printf("\n");
        printf("puzzle #%d:\n", caseno);

        /* 行计算并且输出结果 */
        printf("Across\n");
        wcount = 0;
        for(i=1; i<=r; i++) {
            for(j=1; j<=c; j++)
                if(grid[i][j] != '*' && (grid[i-1][j] == '*' || grid[i][j-1] == '*')) {
                    wcount++;
                    if(grid[i][j-1] == '*')
                        rowoutput(wcount, i, j);
                }
        }

        /* 列计算并且输出结果 */
        printf("Down\n");
        wcount = 0;
        for(i=1; i<=r; i++) {
            for(j=1; j<=c; j++)
                if(grid[i][j] != '*' && (grid[i-1][j] == '*' || grid[i][j-1] == '*')) {
                    wcount++;
                    if(grid[i-1][j] == '*')
                        coloutput(wcount, i, j);
                }
        }
    }

    return 0;
}

 

 

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值