UVALive2701 UVA1189 POJ1426 ZOJ1530 Find The Multiple【BFS】

509 篇文章 9 订阅
281 篇文章 4 订阅

 

Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36074 Accepted: 15064 Special Judge

 

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

Dhaka 2002

 

Regionals 2002 >> Asia - Dhaka

 

问题链接UVALive2701 UVA1189 POJ1426 ZOJ1530 Find The Multiple

问题简述

  输入若干个正整数n,n=0则结束。对于输入的n,输出正整数m,m是n的倍数并且只包含数字0和1。

问题分析

  所求的值不是很大的话,用类型unsigned long long就可以了。开始时,先用1试探,然后是10和11,然后是100、101、110和111,位数逐步增加直到找到能被n整除的数为止。

程序说明

  这个程序虽然在UVALive和UVA上可以AC,但是在POJ上用C++提交是“Time Limit Exceeded”,有点郁闷(狗血剧)。在POJ上用G++提交就AC了。

 

AC通过的C++语言程序如下:

 

/* UVALive2701 UVA1189 POJ1426 ZOJ1530 Find The Multiple */

#include <iostream>
#include <queue>
#include <bitset>

using namespace std;

typedef unsigned long long ULL;

void bfs(int n)
{
    queue<ULL> q;

    q.push(1);

    while(!q.empty()) {
        ULL val = q.front();
        q.pop();

        if(val % n == 0) {
            cout << val << endl;
            break;
        } else {
            q.push(val * 10);
            q.push(val * 10 + 1);
        }
    }
}

int main()
{
    int n;

    while(cin >> n && n != 0)
        bfs(n);

    return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值