POJ1844 Sum【水题+数学题】

Sum
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10839 Accepted: 7107

Description

Consider the natural numbers from 1 to N. By associating to each number a sign (+ or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N.  

For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem.  

Input

The only line contains in the first line a positive integer S (0< S <= 100000) which represents the sum to be obtained.

Output

The output will contain the minimum number N for which the sum S can be obtained.

Sample Input

12

Sample Output

7

Hint

The sum 12 can be obtained from at least 7 terms in the following way: 12 = -1+2+3+4+5+6-7.

Source



问题链接POJ1844 Sum

题意简述:(略)

问题分析:对于n而言,Sn=(n+1)*n/2,需要满足Sn>=S。若存在负的S'(其值为1-n中的若干项之和,即取负值部分)使得Sn-2S'=S,则需要满足(Sn-S)%2=0。

程序说明:(略)


AC的C++语言程序如下:

/* POJ1844 Sum */

#include <iostream>
#include <math.h>

using namespace std;

int main()
{
    int s;

    while(cin >> s) {
        for(int i=sqrt(s); ;i++) {
            int sn = (i + 1) * i / 2;
            if(sn >= s && (sn - s) % 2 == 0) {
                cout << i << endl;
                break;
            }
        }
    }

    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值