POJ3978 Primes【素数筛选+前缀和】

 

Primes

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4075 Accepted: 1579

 

Description

A pretty straight forward task, calculate the number of primes between 2 integers. 

Given 2 integers A ≤ B < 105 what’s the number of primes in range from A to B inclusive. 

Note: A prime number is a positive integer greater than 1 and is divisible by 1 and itself only. For N to be prime it is enough to test the divisibility of numbers less than or equal to square root of N.

Input

As many as 1000 lines, each line contains 2 integers A and B separated by a space. Input is terminated when A = B = -1 (Do not process this line).

Output

For every line in input – except for the last line where A = B = -1 - print the number of prime numbers between A and B inclusive.

Sample Input

0 9999
1 5
-1 -1

Sample Output

1229
3

Source

Seventh ACM Egyptian National Programming Contest

 

 

 

 

问题链接POJ3978 Primes

题意简述:参见上文。

问题分析:用Eratosthenes筛选法筛选素数,然后计算素数数量的前缀和,根据输入的数据范围做个减法即可。

程序说明:(略)

 

参考链接:(略)

 

 

AC的C++语言程序如下:

 

/* POJ3978 Primes */

#include <iostream>
#include <string.h>
#include <math.h>

using namespace std;

const int N = 100000;
int prefixsum[N+1];

// Eratosthenes筛选法+计算前缀和
void sieveofe(int n)
{
    memset(prefixsum, 0, sizeof(prefixsum));

    prefixsum[0] = prefixsum[1] = 1;
    for(int i=2; i<=sqrt(n); i++) {
        if(!prefixsum[i]) {
            for(int j=i*i; j<=n; j+=i)  //筛选
                prefixsum[j] = 1;
        }
    }

    prefixsum[0] = 0;
    for(int i=1; i<=n; i++)
        if(prefixsum[i])
            prefixsum[i] = prefixsum[i - 1];
        else
            prefixsum[i] = prefixsum[i - 1] + 1;
}

int main()
{
    sieveofe(N);

    int a, b;

    while(cin >> a >> b && (a != -1 || b != -1))
        cout << prefixsum[b] - prefixsum[(a - 1 < 0) ? 0 : a - 1] << endl;

    return 0;
}

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值