POJ2247 HDU1058 UVA443 ZOJ1095 Humble Numbers【数学计算+打表+水题】

708 篇文章 18 订阅
509 篇文章 7 订阅

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10731 Accepted: 5015

Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.  

Write a program to find and print the nth element in this sequence.  

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

Source



问题链接POJ2247 HDU1058 UVA443 ZOJ1095 Humble Numbers

问题简述:参见上文

问题分析

计算谦虚数问题,关键在于如何从小到大计算谦虚数。

根据题意,1是谦虚数;谦虚数是2,3,5和7的倍数;最小的谦虚数乘以2,3,5和7是谦虚数。

计算过程的关键是能够按照从小到大顺序算出谦虚数。

打表是必要的,可以避免重复计算。

计算过程中也需要尽量减少计算量。

程序说明 (略)

参考链接:(略)

题记(略)


AC的C++语言程序如下:

/* POJ2247 HDU1058 UVA443 ZOJ1095 Humble Numbers */

#include <iostream>
#include <stdio.h>

using namespace std;

const int N = 5842;
int humble[N];

void maketable(int n)
{
    int i2, i3, i5, i7;
    int h2, h3, h5, h7;

    humble[0] = 1;
    i2 = i3 = i5 = i7 = 0;
    h2 = humble[i2] * 2;
    h3 = humble[i3] * 3;
    h5 = humble[i5] * 5;
    h7 = humble[i7] * 7;
    for(int i=1; i<n; i++) {
        humble[i] = min(min(h2, h3), min(h5, h7));

        if(h2 == humble[i]) {
            h2 = humble[++i2] * 2;
        }
        if(h3 == humble[i]) {
            h3 = humble[++i3] * 3;
        }
        if(h5 == humble[i]) {
            h5 = humble[++i5] * 5;
        }
        if(h7 == humble[i]) {
            h7 = humble[++i7] * 7;
        }
    }
}

int main()
{
    maketable(N);

    int n;
    while(cin >> n && n) {
        if(n%10 == 1 && n % 100 != 11)
            printf("The %dst humble number is ", n);
        else if(n%10 == 2 && n % 100 != 12)
            printf("The %dnd humble number is ", n);
        else if(n%10 == 3 && n % 100 != 13)
            printf("The %drd humble number is ", n);
        else
            printf("The %dth humble number is ", n);
        printf("%d.\n", humble[n - 1]);
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值