UVALive2857 POJ2578 HDU1037 ZOJ2186 Keep on Truckin'【水题】

509 篇文章 9 订阅
281 篇文章 4 订阅

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8462 Accepted: 6418

Description

Boudreaux and Thibodeaux are on the road again . . .  

"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"  

"Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"  

"We're not going to make it, I say!"  

So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?

Input

Input to this problem will consist of a single data set. The data set will be formatted according to the following description.  

The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.

Output

There will be exactly one line of output. This line will be:  

NO CRASH  

if the height of the 18-wheeler is less than the height of each of the underpasses, or:  
CRASH X  

otherwise, where X is the height of the first underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler).  
The height of the 18-wheeler is 168 inches.  

Sample Input

180 160 170

Sample Output

CRASH 160

Source


Regionals 2003 >> North America - South Central USA


问题链接UVALive2857 POJ2578 HDU1037 ZOJ2186 Keep on Truckin'

题意简述:参见上文。

问题分析:值判断问题,对于输入的三个数,输出第1个不大于168的数,如果都大于168则输出“NO CRASH”

程序说明:(略)

题记:(略)


AC的C语言程序如下:

/* UVALive2857 POJ2578 HDU1037 ZOJ2186 Keep on Truckin' */

#include <stdio.h>

#define HEIGHT 168

int main(void)
{
    int a, b, c;
    while (scanf("%d%d%d", &a, &b, &c) != EOF) {
        if (a > HEIGHT && b > HEIGHT && c > HEIGHT)
            printf ("NO CRASH\n");
        else if (a <= HEIGHT)
            printf ("CRASH %d\n",a);
        else if (b <= HEIGHT)
            printf ("CRASH %d\n",b);
        else if (c <= HEIGHT)
            printf ("CRASH %d\n",c);
    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值