POJ1002 487-3279【查表】(Bailian1002, Bailian2974)

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 299207 Accepted: 53544

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.  

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:  

A, B, and C map to 2  
D, E, and F map to 3  
G, H, and I map to 4  
J, K, and L map to 5  
M, N, and O map to 6  
P, R, and S map to 7  
T, U, and V map to 8  
W, X, and Y map to 9  

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.  

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)  

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.  

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.  

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:  

No duplicates.  

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

Source


问题链接POJ1002 Bailian1002 Bailian2974 487-3279

问题简述:为了好记电话号码,将字母映射为数字,人们就可以记忆字母了。给定若干的电话号码,如果没有重复就不输出,如果有重复则输出电话号码及重复次数。如果没有一个电话号码是重复的,则输出“No duplicates”。

问题分析:这个问题的关键是用什么样的数据结构存储有关的信息。需要找到最简洁的字母转换数字的方式,电话号码的存储方式。

程序说明:都是套路。

题记:(略)


参考链接:(略)


AC的C语言程序如下:

/* POJ1002 Bailian1002 Bailian2974 487-3279 */

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <ctype.h>

using namespace std;

int convert[] =
{
    2, 2, 2,
    3, 3, 3,
    4, 4, 4,
    5, 5, 5,
    6, 6, 6,
    7, 0, 7, 7,
    8, 8, 8,
    9, 9, 9,
    0
};

const int N = 128;
char s[N];
const int N2 = 100000;
int ans[N2], acount;

int main()
{
    int t, num;

    scanf("%d", &t);
    for(int k=0; k<t; k++) {
        scanf("%s", s);

        num = 0;
        for(int i=0; s[i]; i++) {
            if(isdigit(s[i])) {
                num *= 10;
                num += s[i] - '0';
            } else if(isupper(s[i])) {
                num *= 10;
                num += convert[s[i] - 'A'];
            }
        }
        ans[k] = num;
    }

    sort(ans, ans + t);

    bool flag = true;
    int count = 1;
    for(int i=1; i<t; i++) {
        if(ans[i] == ans[i - 1])
            count++;
        else {
            if(count > 1) {
                printf("%03d-%04d %d\n", ans[i - 1] / 10000, ans[i - 1] % 10000, count);
                flag = false;
            }
            count = 1;
        }
    }
    if(count > 1) {
        printf("%03d-%04d %d\n", ans[t - 1] / 10000, ans[t - 1] % 10000, count);
        flag = false;
    }

    if(flag)
        printf("No duplicates.\n");

    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值