POJ1552 HDU1303 UVALive2787 ZOJ1760 Doubles【序列】

509 篇文章 6 订阅
281 篇文章 4 订阅

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23199 Accepted: 13094

Description

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list  
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.  

Input

The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

Output

The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output

3
2
0

Source


Regionals 2003 >> North America - Mid-Central USA


问题链接POJ1552 HDU1303 UVALive2787 ZOJ1760 Doubles

问题简述

  输入有若干组整数,最后以-1结束。每组是正整数,以0结束。求每组数中有多少对数,其中的一个是另外一个的两倍。

问题分析

  这个问题的关键是,题意中指出每个数不超过99

  这样问题就简单了,可以做一个标记数组来解决,读到一个数a,就标记数组flag[a]为1。

  同时,判定a的倍数或其一半是否存在就可以了。

程序说明

  需要注意标记数组flag[]的长度。

  标记数组清零是套路。

  使用二重循环实现那是浮云!


题记

  时空可以互换,空间不仅可以换时间,也能换来程序的简洁性。


参考链接:(略)


AC的C语言程序如下:

/* POJ1552 HDU1303 UVALive2787 ZOJ1760 Doubles */

#include <stdio.h>
#include <string.h>

#define TRUE 1
#define FALSE 0
#define MAXN 99
int flag[MAXN * 2 + 1];

int main(void)
{
    int a, count;

    while(~scanf("%d", &a) && a != -1) {
        memset(flag, 0, sizeof(flag));

        count = 0;
        while(a) {
            if(flag[a * 2])
                count++;
            if((a & 1) == 0 && flag[a / 2])
                count++;

            flag[a] = TRUE;

            scanf("%d", &a);
        }

        printf("%d\n", count);
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值