HDU1178 Heritage from father【水题】

Heritage from father

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 6899    Accepted Submission(s): 2584


Problem Description
Famous Harry Potter,who seemd to be a normal and poor boy,is actually a wizard.Everything changed when he had his birthday of ten years old.A huge man called 'Hagrid' found Harry and lead him to a new world full of magic power.  
If you've read this story,you probably know that Harry's parents had left him a lot of gold coins.Hagrid lead Harry to Gringotts(the bank hold up by Goblins). And they stepped into the room which stored the fortune from his father.Harry was astonishing ,coz there were piles of gold coins.  
The way of packing these coins by Goblins was really special.Only one coin was on the top,and three coins consisted an triangle were on the next lower layer.The third layer has six coins which were also consisted an triangle,and so on.On the ith layer there was an triangle have i coins each edge(totally i*(i+1)/2).The whole heap seemed just like a pyramid.Goblin still knew the total num of the layers,so it's up you to help Harry to figure out the sum of all the coins.
 

Input
The input will consist of some cases,each case takes a line with only one integer N(0<N<2^31).It ends with a single 0.
 

Output
对于每个输入的N,输出一行,采用科学记数法来计算金币的总数(保留三位有效数字)
 

Sample Input
 
 
130
 

Sample Output
 
 
1.00E01.00E1
Hint
Hint
when N=1 ,There is 1 gold coins. when N=3 ,There is 1+3+6=10 gold coins.
 

Source

问题链接HDU1178 Heritage from father

问题简述:(略)

问题分析

  求1+3+6+......+i(i+1)/2的和,2其求和公式为N*(N+1)*(N+2)/6,输出结果使用科学记数法。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* HDU1178 Heritage from father */

#include <iostream>
#include <math.h>

using namespace std;

int main()
{
    int n;
    while(scanf("%d", &n) && n) {
        double sum = (double)n * (n + 1) * (n + 2) / 6.0;
        int a = (int) log10(sum);
        sum /= pow(10, a);

        printf("%.2lfE%d\n", sum, a);
    }

    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值