Yup!! The problem name reflects your task; just add a set of numbers. But you may feel yourselves condescended, to write a C/C++ program just to add a set of numbers. Such a problem will simply question your erudition. So, lets add some flavor of ingenuity to it.
Addition operation requires cost now, and the cost is the summation of those two to be added. So, to add 1 and 10, you need a cost of 11. If you want to add 1, 2 and 3. There are several ways
I hope you have understood already your mission, to add a set of integers so that the cost is minimal.
Input
Each test case will start with a positive number, N (2 ≤ N ≤ 5000) followed by N positive integers (all are less than 100000). Input is terminated by a case where the value of N is zero. This case should not be processed.
Output
For each case print the minimum total cost of addition in a single line.
Sample Input
3
1 2 3
4
1 2 3 4
0
Sample Output
9
19
问题链接:UVA10954 Add All
问题简述:(略)
问题分析:
有n个数的集合S,每次从S中删除两个数,然后把它们的和放回集合S,直到剩下一个数。每次操作的开销为那两个数之和,求最小的总开销。
这是一个典型的Huffman编码问题。
程序说明:
使用STL的优先队列实现最为简单,因为其中要不断地排序。
用数据结构的堆排序,效率更高。
题记:(略)
参考链接:(略)
AC的C++语言程序如下:
/* UVA10954 Add All */
#include <bits/stdc++.h>
using namespace std;
int main()
{
int n, a;
while(scanf("%d", &n) != EOF && n) {
priority_queue <int, vector<int>, greater<int> > q;
for(int i = 0; i < n; i++) {
scanf("%d", &a);
q.push(a);
}
int ans = 0;
for(int i = 0; i < n - 1; i++) {
int x = q.top();
q.pop();
int y = q.top();
q.pop();
ans += x + y;
q.push(x + y);
}
printf("%d\n", ans);
}
return 0;
}