POJ2140 HDU2715 Herd Sums【数学】

509 篇文章 6 订阅
132 篇文章 1 订阅

Herd Sums

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18804 Accepted: 10991

Description

The cows in farmer John's herd are numbered and branded with consecutive integers from 1 to N (1 <= N <= 10,000,000). When the cows come to the barn for milking, they always come in sequential order from 1 to N. 

Farmer John, who majored in mathematics in college and loves numbers, often looks for patterns. He has noticed that when he has exactly 15 cows in his herd, there are precisely four ways that the numbers on any set of one or more consecutive cows can add up to 15 (the same as the total number of cows). They are: 15, 7+8, 4+5+6, and 1+2+3+4+5. 

When the number of cows in the herd is 10, the number of ways he can sum consecutive cows and get 10 drops to 2: namely 1+2+3+4 and 10. 

Write a program that will compute the number of ways farmer John can sum the numbers on consecutive cows to equal N. Do not use precomputation to solve this problem. 

Input

* Line 1: A single integer: N 

Output

* Line 1: A single integer that is the number of ways consecutive cow brands can sum to N. 

Sample Input

15

Sample Output

4

Source

USACO 2003 March Orange

 

问题链接POJ2140 HDU2715 Herd Sums

问题描述:(略)

问题分析

  求n=a+a+1+a+2+...+a+k 的组合数。

  n=(k+1)*a+(k+1)*k/2=(k+1)(a+k/2)

  其中,n为整数,k+1为整数,(a+k/2)为整数,k为偶数,k+1为奇数

  当n和k+1确定时,a为定值

  故:解为n的奇因子个数。

程序说明:(略)

参考链接:(略)

题记:(略)

 

AC的C++语言程序如下:

/* POJ2140 HDU2715 Herd Sums */

#include <iostream>

using namespace std;

int main()
{
    int n;
    while(cin >> n) {
        int cnt = 0;
        for(int i = 1; i <= n; i += 2)
            if(n % i == 0)
                cnt++;
        cout << cnt << endl;
    }

    return 0;
}

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值