Cipher
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23315 Accepted: 6502
Description
Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.
The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.
Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.
Input
The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.
Output
Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.
Sample Input
10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0
Sample Output
BolHeol b
C RCE
Source
Regionals 1995 >> Europe - Central
问题链接:POJ1026 HDU1439 UVA306 UVALive521 Cipher
问题描述:(略)
问题分析:
这是一个密码编码计算题,通过置换计算密码。然而,直接通过置换计算进行模拟则容易造成TLE。置换计算有周期性,算出其循环周期,就可以使用模除来减少模拟次数。本题需要做k次置换,k值有可能很大。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C语言程序如下:
/* POJ1026 HDU1439 UVA306 UVALive521 Cipher */
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int N = 200;
int a[N], cycle[N];
char s[N + 1], ans[N + 1];
int main()
{
int n, k;
while(~scanf("%d", &n) && n) {
for(int i = 0; i < n; i++) {
scanf("%d", &a[i]);
a[i]--;
}
// 计算循环数组
for(int i = 0; i < n; i++) {
int cnt = 0, key = i;
while(a[key] != i) cnt++, key = a[key];
cycle[i] = cnt + 1;
}
while(~scanf("%d", &k) && k) {
getchar();
gets(s);
for(int i = strlen(s); i < n; i++)
s[i] = ' ';
for(int i = 0; i < n; i++) {
int t = i, ti = i;
int times = k % cycle[i]; // 对字符s[i],进行times次变换
for(int j = 0; j < times; j++) {
t = a[ti];
ti = t;
}
ans[t] = s[i];
}
ans[n] = '\0';
printf("%s\n", ans);
}
printf("\n");
}
return 0;
}