ZOJ1823 UVA10392 Factoring Large Numbers【因子】

One of the central ideas behind much cryptography is that factoring large numbers is computationally intensive. In this context one might use a 100 digit number that was a product of two 50 digit prime numbers. Even with the fastest projected computers this factorization will take hundreds of years.
You don’t have those computers available, but if you are clever you can still factor fairly large numbers.
Input
The input will be a sequence of integer values, one per line, terminated by a negative number. The numbers will fit in gcc’s long long int datatype, however scanf and printf do not appear to handle this datatype correctly, so you must do your own I/O conversion.
Output
Each positive number from the input must be factored and all factors (other than 1) printed out. The factors must be printed in ascending order with 4 leading spaces preceding a left justified number, and
followed by a single blank line.
Sample Input
90
1234567891
18991325453139
12745267386521023
-1
Sample Output
    2
    3
    3
    5

    1234567891

    3
    3
    13
    179
    271
    1381
    2423
    30971
    411522630413

问题链接ZOJ1823 UVA10392 Factoring Large Numbers
问题简述:(略)
问题分析
    简单题,给定一个数,计算其因子并且输出。因子超过1000000时,只需输出一下原数。
    ZOJ与UVA只是输出数据格式略有不同,没有前导的空格。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序(ZOJ)如下:

/* ZOJ1823 Factoring Large Numbers */

#include <iostream>

using namespace std;

const int N = 1000000;

int main()
{
    long long n;
    while(~scanf("%lld", &n) && n > 0) {
        int i;
        for(i = 2; i <= n && i <= N; i++)
            while(n % i == 0) {
                n /= i;
                printf("%d\n", i);
            }
        if(i > N) printf("%lld\n", n);
        printf("\n");
    }

    return 0;
}

AC的C++语言程序(UVA)如下:

/* UVA10392 Factoring Large Numbers */

#include <iostream>

using namespace std;

const int N = 1000000;

int main()
{
    long long n;
    while(~scanf("%lld", &n) && n > 0) {
        int i;
        for(i = 2; i <= n && i <= N; i++)
            while(n % i == 0) {
                n /= i;
                printf("    %d\n", i);
            }
        if(i > N) printf("    %lld\n", n);
        printf("\n");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值