poj 2083 Fractal(分形)

Fractal
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10899 Accepted: 4876

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales. 
A box fractal is defined as below : 
  • A box fractal of degree 1 is simply 

  • A box fractal of degree 2 is 
    X X 

    X X 
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following 
    B(n - 1)        B(n - 1)
    
            B(n - 1)
    
    B(n - 1)        B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-

Source


题意:

画分形图形。

思路:

思路来源 https://blog.csdn.net/hackbuteer1/article/details/7321602

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
char mp[8][740][740];
void dfs(int c,int n,int i,int j)
{
    int size;
    if(n==1)
    {
        mp[c][i][j]='X';
        return;
    }
    size=pow(3.0,n-2);
    dfs(c,n-1,i,j);
    dfs(c,n-1,i+2*size,j);
    dfs(c,n-1,i+size,j+size);
    dfs(c,n-1,i,j+size*2);
    dfs(c,n-1,i+size*2,j+size*2);
}
int main()
{
    int n,size;
    for(int k=1;k<=7;k++)
    {
        size=(int)pow(3,k-1);
        for(int i=1;i<=size;i++)
        {
            for(int j=1;j<=size;j++)
            {
                mp[k][i][j]=' ';
            }
        }
        dfs(k,k,1,1);
    }
    while(~scanf("%d",&n)&&n!=-1)
    {
        size=(int)pow(3,n-1);
        for(int i=1;i<=size;i++)
        {
            for(int j=1;j<=size;j++)
            {
                putchar(mp[n][i][j]);
            }
            printf("\n");
        }
        printf("-\n");
    }
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值