02-线性结构4 Pop Sequence (25分)

Given a stack which can keep MM numbers at most. Push NN numbers in the order of 1, 2, 3, ..., NN and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if MM is 5 and NN is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): MM (the maximum capacity of the stack), NN (the length of push sequence), and KK (the number of pop sequences to be checked). Then KK lines follow, each contains a pop sequence of NN numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题目的大概意思就是给定一个堆栈的容量M,要按顺序push N个自然数1,2,...,N进入堆栈并且随机的pop它,判断能否pop出以下的K个序列。


#include <iostream>
#include <stack>
#include <cstdio>
using namespace std;

int main()
{
	#ifdef LOCAL
	freopen("d:\\in.txt","r",stdin);
	#endif


	int M,N,K;
	cin >> M >> N >> K;
	stack<int> st;
	for(int i=0;i<K;i++){
		int t,j=1,time=N;
		bool isable = true;
		while(!st.empty()) st.pop();
		while(time--){
			cin >> t;
			for(;j<=t;j++){
				st.push(j);
				if(st.size()>M) isable = false;
			}
			if(t==st.top()) st.pop();
			else isable = false;
		}
		if(isable) cout << "YES" << endl;
		else cout << "NO" << endl;
	}
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值