POJ2456 Aggressive cows

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11665 Accepted: 5716

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

Source

USACO 2005 February Gold


题意:求最短间隔的最大值。
解题思路:典型的二分查找题目,用二分查找猜测可能的最大间距即可。对于每一个猜测值,看看在这个距离下能容纳多少牛,如果可容纳的牛数多余总牛数,说明距离过短,扩大左边界;否则,距离过长,减小右边界。


#include <iostream>
#include <cstdio>
#include <stdlib.h>
using namespace std;
int pos[100005];
int N,C;

int cmp(const void* a,const void* b)  //比较函数
{
	return *(int*)a-*(int*)b;
}

bool check(int mid){
	int cnt=0,pre=pos[0];
	for(int i=1;i<N&&cnt<C;i++){
		if(pos[i]-pre>=mid){
			pre=pos[i];
			cnt++; //cnt计数在mid的间距下能容纳的总牛数
		}
	}
	if(cnt>=C-1) return true; //C头牛有C-1个间距
	return false;
}

int main()
{
    scanf("%d%d",&N,&C);
    for(int i=0;i<N;i++){
		scanf("%d",&pos[i]);
    }
    qsort(pos,N,sizeof(int),cmp);//快速排序
    int l,r,mid;
    //设置左右边界
    l=0;
    r=pos[N-1];
    mid=l+(r-l)/2;//设置中间值,相当于(l+r)/2 ,这样写防止(l+r)溢出
    while(l+1<r){ //二分查找最短间隔的最大值
		mid=l+(r-l)/2;
		if(check(mid)) l=mid;
		else r=mid;
    }
    printf("%d",l);

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值