Printer Queue UVA - 12100

题目:

The only printer in the computer science students’ union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output.

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, and 1 being the lowest), and the printer operates as follows.

• The first job J in queue is taken from the queue.

• If there is some job in the queue with a higher priority than job J, then move J to the end of the queue without printing it.

• Otherwise, print job J (and do not put it back in the queue).

In this way, all those important muffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that’s life.

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplify matters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case: • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n − 1). The first position in the queue is number 0, the second is number 1, and so on. • One line with n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Sample Input

3

1 0

5

4 2

1 2 3 4

6 0

1 1 9 1 1 1

Sample Output

1

2

5

题意:

让你打印文件,每一份文件有一个优先级,优先级0--9,数字越大优先级越高,当你打印时,有人的优先级高,那么你就会进入队列的最后面;要求让你输出你什么时候才能打印完毕;打印每一份文件需要时间1,出入队列不需要时间;

给你一个字母T,代表有T组测试数据;

每一组测试数据,两个数字N,M,代表数据有N个数字,你所在的位置是M,位置编号是从0开始的;

思路:

直接把数据入队列,再把优先级进行排序,然后对于队列进行模拟操作,最后输出结果即可;

代码如下:

#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;

const int N=110;

int t,n,m,sum;
int a[N];

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        queue<int>Q;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            Q.push(a[i]);
        }
        sort(a,a+n);
        sum=0;//耗费的时间;
        for(int i=0;;i++)
        {//n标记着你现在的优先级的位置;
            if(a[n-1]>Q.front())//优先级比你大;进入队列末尾;
            {
                Q.push(Q.front());
                Q.pop();
                if(m==0)
                    m=n-1;
                else
                    m--;
            }
            else//否则这个位置的先打印;
            {
                Q.pop();
                n--;
                sum++;
                if(m==0)
                    break;
                else
                    m--;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值