Division UVA - 725

题目:

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where 2 ≤ N ≤ 79.

That is, abcde / fghij = N

where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input

Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.

Output

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator). Your output should be in the following general form: xxxxx / xxxxx = N xxxxx / xxxxx = N . . In case there are no pairs of numerals satisfying the condition, you must write ‘There are no solutions for N.’. Separate the output for two different values of N by a blank line.

Sample Input

61

62

0

Sample Output

There are no solutions for 61.

 

79546 / 01283 = 62

94736 / 01528 = 62

题意:

给你一个数字 N,让你求出来所有的A/B=N的结果,但是0--9只能出现一次;

思路:

直接暴力进行判断,循环B,然后判断 A*N 和 B 是否满足题目的要求,然后输出;

注意输出,每两个测试数据之间输出一个空行;

A和B都是占据5位;

代码如下:

#include<map>
#include<stack>
#include<queue>
#include<deque>
#include<string>
#include<vector>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;

int a[10];//记录哪个数字出现过;
int n;

int panduan(int x,int y)
{
    int t;
    memset(a,0,sizeof a);
    for(int i=0; i<5; i++)
    {
        t=x%10;
        x=x/10;
        if(a[t]==1)//已经出现过,即出现重复;
            return 0;
        a[t]=1;
    }
    for(int i=0; i<5; i++)
    {
        t=y%10;
        y=y/10;
        if(a[t]==1)
            return 0;
        a[t]=1;
    }
    return 1;
}

int main()
{
    int tt=0;
    while(~scanf("%d",&n)&&n)
    {
        int kk,flag=0;
        if(tt==0)//注意输出格式;
            tt=1;
        else
            printf("\n");
        for(int i=1234; i<100000; i++)
        {
            if(n*i<100000)//超出5位数;
                kk=panduan(i,n*i);
            if(kk==1)
            {
                printf("%05d / %05d = %d\n",n*i,i,n);
                flag=1;
            }
        }
        if(flag==0)
            printf("There are no solutions for %d.\n",n);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值