Agri-Net POJ - 1258

题目:

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

题意:

给你一个数字N,代表有N个城市,让你把这N个城市全部连接在一起,算出最小需要的光纤长度;

思路:

直接用最小生成树算法进行求解;

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int inf=99999999;
const int N=1010;

int t,n,sum;
int dis[N];
int book[N];
int map[N][N];

void init()//初始化;
{
    int i,j;
    for(i=1; i<=n; i++)
    {
        for(j=1; j<=n; j++)
        {
            if(i==j)
                map[i][j]=0;
            else
                map[i][j]=inf;
        }
    }
}

void prim()
{
    int i,j,k,minn;
    memset(book,0,sizeof book);
    book[1]=1;
    int count=0;
    sum=0;
    count++;//加入生成树的边的条数;
    while(count<n)//n个点需要n-1条边进行连接;
    {
        minn=inf;
        for(i=1; i<=n; i++)//找出最短的边加入生成树;
        {
            if(book[i]==0&&dis[i]<minn)
            {
                minn=dis[i];
                k=i;
            }
        }
        book[k]=1;
        count++;
        sum+=dis[k];//生成树的值;
        for(j=1; j<=n; j++)
        {
            if(book[j]==0&&dis[j]>map[k][j])
                dis[j]=map[k][j];
        }
    }
    return ;
}

int main()
{
    while(~scanf("%d",&n))
    {
        int i,j;
        init();
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                scanf("%d",&map[i][j]);
            }
        }
        for(i=1; i<=n; i++)
        {
            dis[i]=map[1][i];
        }
        prim();
        printf("%d\n",sum);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值