题目1486:False coin

题目描述:
The “Gold Bar”bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan.
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded.
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.
输入:
The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: ‘<’, ‘>’, or ‘=’. It represents the result of the weighting:
‘<’ means that the weight of coins in the left pan is less than the weight of coins in the right pan,
‘>’ means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
‘=’ means that the weight of coins in the left pan is equal to the weight of coins in the right pan.
输出:
Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.
样例输入:
5 3
2 1 2 3 4
<

1 1 4

1 2 5

样例输出:
3

#include<iostream>
#include<vector>
#define FALSE 0
#define TRUE 1

using namespace std;


/*
该题目主要的模拟,不涉及数据结构和算法的相关知识。

因为还有=号的式子一定是真硬币,而还有大于号和小于号的式子肯定含有假硬币
所以对于所有的不等式,将轻硬币放在lightCoins里,将重硬币放在heavyCoins里,
因为只有一个假硬币,所以最后假硬币的出现在lightCoins或者HeavyCoins的次数一定和不等式的次数相等

*/

int main()
{
    int n, k;
    while (cin >> n >> k)
    {
        vector<int> coins(n+1, FALSE);//设置大小为n+1的数组,并且设置所有的coin为false
        vector<int> lightCoins(n + 1, 0);//初始化轻硬币出现的次数为0
        vector<int> heavyCoins(n + 1, 0);//初始化重硬币出现的次数为1

        int noEqualNums = 0;//是不等式出现的次数

        for (int i = 0; i < k; i++)
        {
            int nums;
            cin >> nums;
            vector<int> tempCoins;
            for (int j = 0; j < 2 * nums; j++)
            {
                int x;
                cin >> x;
                tempCoins.push_back(x);
            }
            char c;
            cin >> c;
            if (c == '=')
            {
                for (int j = 0; j < 2 * nums; j++)
                {
                    coins[tempCoins[j]] = TRUE;
                }
            }
            else if (c=='<')//则右边的硬币都是正确的
            {
                for (int j = 0; j < nums; j++)
                {
                    lightCoins[tempCoins[j]]++ ;//左边的放在轻硬币中
                }
                for (int j = nums; j < 2 * nums; j++)
                {
                    heavyCoins[tempCoins[j]]++ ;//重的放在重硬币中
                }
                noEqualNums++;
            }
            else
            {
                for (int j = 0; j < nums; j++)
                {
                    heavyCoins[tempCoins[j]]++;
                }
                for (int j = nums; j < 2 * nums; j++)
                {
                    lightCoins[tempCoins[j]]++;
                }
                noEqualNums++;
            }

        }

        int ansNums=0;
        int ans;
        for (int i = 1; i <= n; i++)
        {
            if (coins[i] == FALSE&&(heavyCoins[i]==noEqualNums||lightCoins[i]==noEqualNums))//满足条件
            {
                ansNums++;
                ans = i;
            }
        }

        if(ansNums == 1)
        {
            cout << ans << endl;//如果最后的答案只要一个,则输出
        }
        else
        {
            cout << 0 << endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值