(甲)1008 Elevator (20 分)

题目:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

 题意:

给你一个数字N,代表有N个乘客,后面跟着N个数据,是电梯需要停下的楼层数;

只有一个电梯,电梯每上一层需要耗时6秒,下降一层需要耗时4秒,每一次停留需要耗时5秒;

当最后一位乘客乘坐结束后电梯没必要回到0层;

让你求出来所有乘客乘坐结束后消耗的时间;

思路:

直接模拟,判断电梯需要上下多少层再乘上对应的上下一层需要的时间,记得加上停留消耗的时间;

需要注意的是,没必要判断一层会有多个人下电梯,题目隐含的意思是每下一个人都要消耗5秒。。。。。。嗯呐,最开始判断了这个问题,2,3,6组测试数据错了。。。。。

代码如下:

错误代码:2,3,6组测试数据没过。

#include<stdio.h>
#include<string.h>

int n,a[110];

int main()
{
    while(~scanf("%d",&n))
    {
        memset(a,0,sizeof a);
        int sum=0,k=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=0; i<n; i++)
        {
            if(a[i]!=a[i+1])
            {
                if(k<=a[i])
                {
                    sum+=(a[i]-k)*6+5;
                    k=a[i];
                }
                else
                {
                    sum+=(k-a[i])*4+5;
                    k=a[i];
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

正确代码:

#include<stdio.h>
#include<string.h>

int n,a[110];

int main()
{
    while(~scanf("%d",&n))
    {
        memset(a,0,sizeof a);
        int sum=0,k=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=0; i<n; i++)
        {
            if(k<=a[i])
            {
                sum+=(a[i]-k)*6+5;
                k=a[i];
            }
            else
            {
                sum+=(k-a[i])*4+5;
                k=a[i];
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值