1008 Elevator (20 分)(水题)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题意:

有一部电梯,最开始停在0层,上一层需要6s,下一层需要4s, 每次到达当前楼层还需要停5s,。现在给出要去的楼层顺序,求总共需要花费多少时间(最后不需要回到0层)(N less than 100)

样例中: 2 * 6 + 5 = 17,  1 * 6 + 5 = 11, 2 * 4 + 5 = 13; 17 + 11 + 13 = 41

本题属于简单题

#include <cstdio>
int main(){
  int n, past = 0, time = 0, ans = 0;
  scanf("%d", &n);
  for(int i = 0; i < n; i++){
    int now;
    scanf("%d", &now);
    if(past < now){
      time = (now - past) * 6 + 5;
    }
    else{
      time = (past - now) * 4 + 5;
    }
    ans += time;
    past = now;
  }
  printf("%d", ans);
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值