ZOJ 3471 Most Powerful (状态压缩)

Most Powerful

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22


Author:  GAO, Yuan
Contest:  ZOJ Monthly, February 2011


题意:

和旅行商问题类似,每次挑选两个原子, 碰撞后产生能量,一个消失。问最多得到的能量。

思路:

简单的状态压缩……至今不知道为什么二维数组的状态压缩会WA。。可能我写的有毒。



#include <cstdio>
#include <iostream>
#include <cstring>
#define MAX 1000100

int dp[2100];
int map[12][12];

using std::max;

int main()
{
	int num, top, i, j, k, l;
	while(~scanf("%d", &num) && num){
		
		for(i = 1; i <= num; i++)
			for(j = 1; j <= num; j++)
				scanf("%d", &map[i][j]);
		top = (1 << num);
		memset(dp, 0, sizeof(dp));
		int res = 0;
		for(j = 0; j < top; j++)
			for(k = 0; k < num; k++){
				if(j & (1 << k)) continue;
				for(l = 0; l < num; l++){
					if(k == l) continue;
					if(j & (1 << l)) continue;
					dp[j | (1 << l)] = max(dp[j | (1 << l)], dp[j] + map[k + 1][l + 1]);
					if(dp[j | (1 << l)] > res)  res = dp[j | (1 << l)];
				}
			}

		printf("%d\n", res);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值