zoj 3471 状态压缩dp

Most Powerful

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22


 wa了10几次才回过神来
思路 d[i] 表示状态i 下的最大值,可以采用正序,也可采用逆序
以下为逆序和正序两种
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int INF = 0x3f3f3f3f;
int  n,m;
int dp[1<<11];
int mp[11][11];
void DP()
{
    int bound = 1<<n;
    int ans = 0;
    for(int i = 0 ; i < bound - 1; ++i){
            for(int j =0 ; j < n ; ++j) if((i&(1<<j)) ) continue; else{
                    for(int k = 0 ; k < n ; ++k)
                           {
                           if(j == k || (i&(1<<k)) == 0 ) continue;
                           dp[i] = max(dp[i],dp[i^(1<<k)] + mp[j][k]);
                           }
            }
             ans = max(dp[i],ans);
    }   

    printf("%d\n",ans);
}
int main()
{
    while(scanf("%d",&n),n){
        memset(dp,0,sizeof(dp));

        for(int i = 0 ; i < n ; ++i)
                for(int j = 0 ; j < n ; ++j) scanf("%d",&mp[i][j]);
        DP();
    }
	return 0;
}


#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int M = 1024;
int dp[M+10];
int n,a[11][11];
int main()
{

    while(scanf("%d", &n), n){
        memset(dp, 0, sizeof(dp));
        int ans = 0 ;
        for(int i = 0 ; i < n ; ++i)
                for(int j = 0 ; j < n ; ++j)
                        scanf("%d",&a[i][j]);
        int bound = 1<<n;
        for(int i = 0; i < bound; ++i){
                for(int  j = 0 ; j < n ; ++j) if(i&(1<<j)) continue; else
                        for(int k = 0 ; k < n ; ++k) if(k == j || i & (1<<k)) continue; else
                                dp[i|(1<<j)] = max(dp[i|(1<<j)],dp[i] + a[k][j]);

        ans = max(ans,dp[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值