POJ 2386 Lake Counting

原题链接

Description
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John’s field, determine how many ponds he has.

Input
* Line 1: Two space-separated integers: N and M

Output
* Line 1: The number of ponds in Farmer John’s field.

Sample Input
10 12
W……..WW.
.WWW…..WWW
….WW…WW.
………WW.
………W..
..W……W..
.W.W…..WW.
W.W.W…..W.
.W.W……W.
..W…….W.

Sample Output
3

Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.

经典深搜

AC代码:

#include <iostream>
using namespace std;

int n,m;
char f[100][101]; 
void dfs(int x,int y){
    int i,j;
    f[x][y]='.';
    for(i=-1;i<=1;i++){
        for(j=-1;j<=1;j++){
            int dx=x+i;
            int dy=y+j;
            if(dx>=0 && dx<n && dy>=0 && dy<m && f[dx][dy]=='W')  dfs(dx,dy);
        }
    }
    return;
}
int main()
{
    int i,j;
    cin>>n>>m;
    for(i=0;i<n;i++){
        cin>>f[i];
    }
    int res=0;
    for(i=0;i<n;i++){
        for(j=0;j<m;j++){
            if(f[i][j]=='W'){
                dfs(i,j);
                res++;
            }
        }
    }
    cout<<res<<endl;
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值