POJ 3125 (Queue)

Printer Queue
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2817 Accepted: 1523

Description

The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output. 

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, 
and 1 being the lowest), and the printer operates as follows.
  • The first job J in queue is taken from the queue.
  • If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
  • Otherwise, print job J (and do not put it back in the queue).
In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life. 

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:
  • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
  • One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Sample Input

3

1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1

Sample Output

1

2

5


队列模拟

#include <iostream>
#include <cstdio>
#include <queue>
#include <algorithm>

using namespace std;

struct job
{
    int priority;
    int index;
};

bool cmp(int l, int r)
{
    return l > r;
}

int printer()
{
    //freopen("printer_testcase", "r", stdin);
    int C;
    cin >> C;
    while(C--)
    {
        int n,m;
        cin >> n >> m;

        int a[101];
        job j[101];
        queue<job> q;

        for(int i = 0; i < n; i++)
        {
            cin>>a[i];
            j[i].index = i;
            j[i].priority = a[i];
            q.push(j[i]);
        }

        sort(a, a+n, cmp);


        int time = 0;
        int top = 0;

        while(1)
        {
            job tmp = q.front();
            q.pop();
            if(tmp.index == m && tmp.priority == a[top])
            {
                break;
            }
            else if(tmp.index != m && tmp.priority == a[top])
            {
                top++;
                time++;
            }
            else
            {
                q.push(tmp);
            }
        }
        cout << time <<endl;
    }

    return 0;
}


队列模拟

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 3635 是一道比较经典的数学题目,主要考察了一些数学知识和算法。下面是这道题的 Java 解题思路和代码实现: 题目描述: 给定一个正整数N,求最小的正整数M,使得 N*M 的十进制表示中只包含数字0和1。 输入格式: 一个正整数N。 输出格式: 一个正整数M,表示满足条件的最小正整数M。 Java 代码实现: ```java import java.util.*; public class Main { public static void main(String[] args) { Scanner sc = new Scanner(System.in); long n = sc.nextLong(); long res = 1; Queue<Long> queue = new LinkedList<>(); Set<Long> set = new HashSet<>(); queue.offer(1L); set.add(1L); while (!queue.isEmpty()) { long t = queue.poll(); if (t % n == 0) { res = t; break; } long a = (t * 10) % n; long b = (t * 10 + 1) % n; if (!set.contains(a)) { queue.offer(a); set.add(a); } if (!set.contains(b)) { queue.offer(b); set.add(b); } } System.out.println(res); } } ``` 思路解析: 这道题的解题思路比较巧妙,我们可以采用 BFS 算法来解决。我们可以从 1 开始进行 BFS,每次将当前的数乘以 10 或者乘以 10 再加上 1,得到两个新的数,然后判断这两个新的数是否是 n 的倍数,如果是,则找到了最小的满足条件的数,退出 BFS。如果不是,则将两个新的数加入队列,继续进行 BFS。需要注意的是,由于 N 可能非常大,所以我们需要使用 long 类型来存储数值,同时我们需要使用集合来避免重复计算。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值