Window Pains
Description
Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux's windows would be represented by the following 2 x 2 windows:
Unfortunately, Boudreaux's computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . . Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.
A single data set has 3 components:
After the last data set, there will be a single line: ENDOFINPUT Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant. Output
For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux's screen, the output will be a single line with the statement:
THESE WINDOWS ARE CLEAN Otherwise, the output will be a single line with the statement: THESE WINDOWS ARE BROKEN Sample Input START 1 2 3 3 4 5 6 6 7 8 9 9 7 8 9 9 END START 1 1 3 3 4 1 3 3 7 7 9 9 7 7 9 9 END ENDOFINPUT Sample Output THESE WINDOWS ARE CLEAN THESE WINDOWS ARE BROKEN Source |
题意:给定窗口叠放后的状态 让你判断电脑是否死机
问题转化:对1~9号窗口进行拓扑排序,如果合理则未死机,反之则反。
建图思路:对方块进行分析,一个方块被多个窗口覆盖,方块显示的是最上面的窗口,则可以将其他的窗口与最上面的建立大小关系(建边)。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <stack>
#define maxn 15
using namespace std;
int n,m,ans;
int a[10][10];
int node[5][5][5];
int num[maxn];
char s[50];
vector<int>v[maxn];
stack<int>sta;
void addedge() // 建边
{
int i,j,k,nx;
memset(num,0,sizeof(num));
for(i=1; i<=4; i++)
{
for(j=1; j<=4; j++)
{
nx=a[i][j];
for(k=1;node[i][j][k]!=0;k++)
{
if(node[i][j][k]!=nx)
{
num[node[i][j][k]]++;
v[nx].push_back(node[i][j][k]);
}
}
}
}
}
bool tuopusort()
{
int i,j,nx,cnt=0,sz;
while(!sta.empty()) sta.pop();
for(i=1;i<=9;i++)
{
if(num[i]==0) sta.push(i);
}
while(!sta.empty())
{
nx=sta.top();
cnt++;
sta.pop();
sz=v[nx].size();
for(i=0;i<sz;i++)
{
num[v[nx][i]]--;
if(num[v[nx][i]]==0) sta.push(v[nx][i]);
}
}
if(cnt==9) return true ;
return false ;
}
int main()
{
int i,j;
memset(node,0,sizeof(node));
node[1][2][1]=1; node[1][2][2]=2; // 对每个方块可能显示的窗口打表
node[1][3][1]=2; node[1][3][2]=3;
node[2][1][1]=1; node[2][1][2]=4;
node[2][2][1]=1; node[2][2][2]=2; node[2][2][3]=4; node[2][2][4]=5;
node[2][3][1]=2; node[2][3][2]=3; node[2][3][3]=5; node[2][3][4]=6;
node[2][4][1]=3; node[2][4][2]=6;
node[3][1][1]=4; node[3][1][2]=7;
node[3][2][1]=4; node[3][2][2]=5; node[3][2][3]=7; node[3][2][4]=8;
node[3][3][1]=5; node[3][3][2]=6; node[3][3][3]=8; node[3][3][4]=9;
node[3][4][1]=6; node[3][4][2]=9;
node[4][2][1]=7; node[4][2][2]=8;
node[4][3][1]=8; node[4][3][2]=9;
while(scanf("%s",s),strcmp(s,"ENDOFINPUT")!=0)
{
for(i=1; i<=4; i++)
{
for(j=1; j<=4; j++)
{
scanf("%d",&a[i][j]);
}
}
for(i=1; i<=9; i++)
{
v[i].clear();
}
addedge();
if(tuopusort()) printf("THESE WINDOWS ARE CLEAN\n");
else printf("THESE WINDOWS ARE BROKEN\n");
scanf("%s",s);
}
return 0;
}