1058. 选择题(20)
批改多选题是比较麻烦的事情,本题就请你写个程序帮助老师批改多选题,并且指出哪道题错的人最多。
输入格式:
输入在第一行给出两个正整数N(<=1000)和M(<=100),分别是学生人数和多选题的个数。随后M行,每行顺次给出一道题的满分值(不超过5的正整数)、选项个数(不少于2且不超过5的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母a开始顺次排列。各项间以1个空格分隔。最后N行,每行给出一个学生的答题情况,其每题答案格式为“(选中的选项个数 选项1 ……)”,按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。
输出格式:
按照输入的顺序给出每个学生的得分,每个分数占一行。注意判题时只有选择全部正确才能得到该题的分数。最后一行输出错得最多的题目的错误次数和编号(题目按照输入的顺序从1开始编号)。如果有并列,则按编号递增顺序输出。数字间用空格分隔,行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出“Too simple”。
输入样例:3 4 3 4 2 a c 2 5 1 b 5 3 2 b c 1 5 4 a b d e (2 a c) (2 b d) (2 a c) (3 a b e) (2 a c) (1 b) (2 a b) (4 a b d e) (2 b d) (1 e) (2 b c) (4 a b c d)输出样例:
3 6 5 2 2 3 4
分析:
这个题目的考点应该在于大量字符串的处理,要注意到,由于数字都是一位数,所以输入字符串的哪一个位置是哪一个字符是非常明确的,这样就不难啦~~倒数第二题了!
using System;
namespace PAT
{
class Program
{
static void Main()
{
string[] infos = Console.ReadLine().Split(' ');
int stuNum = int.Parse(infos[0]);
int topicNum = int.Parse(infos[1]);
int[] wrongTimes = new int[topicNum];
int[] topicScores = new int[topicNum];
int[] rightNumbers = new int[topicNum];
string[][] rightAnswers = new string[topicNum][];
string answerInfos;
string[] numStrs;
string answerStr;
for (int i = 0; i < topicNum; i++)
{
answerInfos = Console.ReadLine();
numStrs = answerInfos.Substring(0, 5).Split(' ');
answerStr = answerInfos.Substring(6);
topicScores[i] = int.Parse(numStrs[0]);
rightNumbers[i] = int.Parse(numStrs[2]);
rightAnswers[i] = answerStr.Split(' ');
}
int[] sumScore = new int[stuNum];
string[,] studentAnswer = new string[stuNum, topicNum];
string[] stuAnsInfos;
bool flag;
for (int i = 0; i < stuNum; i++)
{
infos = Console.ReadLine().Split(')');
for (int j = 0; j < topicNum; j++)
{
stuAnsInfos = infos[j].Split('(');
studentAnswer[i, j] = stuAnsInfos[stuAnsInfos.Length - 1];
if (studentAnswer[i, j][0] - '0' == rightNumbers[j])
{
flag = true;
for (int k = 1; k <= rightNumbers[j]; k++)
{
if (studentAnswer[i, j][2 * k] != char.Parse(rightAnswers[j][k - 1]))
flag = false;
}
if (flag)
sumScore[i] += topicScores[j];
else
wrongTimes[j]++;
}
else
wrongTimes[j]++;
}
}
for (int i = 0; i < stuNum; i++)
Console.WriteLine(sumScore[i]);
int mostWrongTimes = 0;
for (int i = 0; i < topicNum; i++)
if (mostWrongTimes < wrongTimes[i])
mostWrongTimes = wrongTimes[i];
if (mostWrongTimes == 0)
Console.WriteLine("Too simple");
else
{
Console.Write("{0} ", mostWrongTimes);
string msg = "";
for(int i = 0; i < topicNum; i++)
{
if (mostWrongTimes == wrongTimes[i])
msg += (i+1) + " ";
}
Console.WriteLine(msg.TrimEnd());
}
}
}
}