HDU 1372 Knight Moves(BFS)

Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 
 

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.". 
 

Sample Input
  
  
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6
 

Sample Output
  
  
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.
 

//Must so
#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>
#include<ctype.h>
#include<queue>
#include<vector>
#include<set>
#include<cstdio>
#include<cmath>
#define mem(a,x) memset(a,x,sizeof(a))
#define inf 1<<30
#define NN 1000006
using namespace std;
const double PI = acos(-1.0);
typedef long long LL;

/**********************************************************************
根据马走“日”的规则,在一个8*8的棋盘上取两点,问从起点到终点最少步数
根据BFS的特点,最先到达的路径一定是最短的,于是用BFS广搜
类似题目还有POJ-2488-A Knight`s Journey
**********************************************************************/
struct Node
{
    int x,y,ans;
} s,e; //起点和终点
bool vis[10][10];
int dx[8] = {-1,1,-2,2,-1,1,-2,2};
int dy[8] = {-2,-2,-1,-1,2,2,1,1};
int bfs()
{
    mem(vis,0);
    queue<Node>q;//队列
    q.push(s);//起点入队
    vis[s.x][s.y] = 1;//标记在队列中
    while (!q.empty())
    {
        Node vn = q.front();
        q.pop();
        vis[vn.x][vn.y] = 0;
        for (int i = 0; i < 8; i++) //8个方向
        {
            Node vw ;
            vw.x = vn.x+dx[i];
            vw.y = vn.y+dy[i];
            vw.ans = vn.ans+1;
            if (vw.x == e.x&&vw.y == e.y)//到达终点
            {
                return vw.ans;
            }
            if (vw.x >= 0&&vw.y >= 0&&vw.x < 8&&vw.y < 8&&vis[vw.x][vw.y] == 0)
            {
                q.push(vw);//入队
                vis[vw.x][vw.y] = 1;//标记在队列中
            }
        }
    }
}
int main()
{
    string a,b;
    while (cin>>a>>b)
    {
        if (a == b)
        {
            cout<<"To get from "<<a<<" to "<<b<<" takes 0 knight moves."<<endl;
            continue;
        }
        s.x = a[0] - 'a',s.y = a[1] - '1',s.ans = 0;
        e.x = b[0] - 'a',e.y = b[1] - '1';
        cout<<"To get from "<<a<<" to "<<b<<" takes "<<bfs()<<" knight moves."<<endl;
    }
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值