POJ 1129 Channel Allocation(dfs模拟图的上色问题)

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

Source


当年,数学老师要我们从1加到100,高斯一下子就算出来了,

鶸心里不爽,于是敲了 int sun = 0;for (int i = 1;i <= 100;++i)sun += i;cout<<sun<<endl;

如今,数学老师,给出n个点的图,其中相连的点不能涂一样的颜色,

问最少使用多少种颜色,不会四色定理的鶸于是又来敲代码了

思路很简单,直接模拟本鶸给图上色的过程。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#define mem(a,x) memset(a,x,sizeof(a))
#define esp 1e-8
using namespace std;
typedef long long ll;
/*
    我的想法是dfs模拟涂色过程
    每涂一个点,判断该点是否可以用已经用过的颜色涂
    不能的话需要的颜色就加一
    26个点,需要的颜色最多也就26个
*/
const int N = 26;
bool mp[N+5][N+5];
int n,ans;
int cl[N+5];//c[i]表示点i的颜色
bool check(int u,int c)//检查给u点上颜色c是否满足
{
    for (int i = 0;i < n;++i)
    {
        if (mp[u][i]&&cl[i] == c)//相邻的点染了一样的颜色
        {
            return 0;//不行
        }
    }
    return 1;
}
bool fd;
void dfs(int p,int uc)//搜到p点使用了uc个颜色
{
    if (p >= n) fd = 1;//找到方案把所有点涂完了
    if (fd) return;
    for (int i = 1;i <= uc;++i)//在使用过的颜色里找一个看能不能涂
    {
        if (check(p,i))
        {
            cl[p] = i;//那么就涂
            dfs(p+1,uc);//搜下一个点,使用的颜色没有增加
            cl[i] = 0;
        }
    }
    if (!fd)
    {
        ans ++;
        dfs(p,uc+1);
    }
}
char s[1000];
int main()
{
    while (scanf("%d",&n) == 1&&n)
    {
        getchar();
        mem(mp,0);mem(cl,0);
        for (int i = 0;i < n;++i)
        {
            gets(s);
            for (int i = 2;s[i]!='\0';++i)
            {
                mp[s[0]-'A'][s[i]-'A'] = 1;//连线
            }
        }
        fd = 0;ans = 1;
        dfs(0,1);
        printf("%d channe%s needed.\n",ans,ans==1?"l":"ls");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值