joj1197(深搜,Sum it up)

1197: Sum It Up


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K640256Standard

Given a specified total t and a list of n integers, find all distinct sumsusing numbers from the list that add up tot. For example,ift = 4,n = 6, and the list is [4, 3, 2, 2, 1, 1], then there arefour different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can beused within a sum asmany times as it appears in the list, and a single number counts as a sum.)Your job is to solve this problem in general.

 

Input

The input file will contain one or more test cases, one per line. Each testcase contains t, the total,followed by n, the number of integers in the list, followed by n integers .If n = 0 itsignals the end of the input; otherwise, t will be a positive integer lessthan 1000, n will be aninteger between 1 and 12 (inclusive), and will be positive integers less than 100. Allnumbers will be separated by exactly one space. The numbers in each listappear in nonincreasing order, and there may be repetitions.

 

Output

For each test case, first output a line containing ` Sums of ', the total, anda colon. Then outputeach sum, one per line; if there are no sums, output the line ` NONE'.The numbers within eachsum must appear in nonincreasing order. A number may be repeated in the sumas many timesas it was repeated in the original list. The sums themselves must be sortedin decreasing orderbased on the numbers appearing in the sum. In other words, the sums must besorted by theirfirst number; sums with the same first number must be sorted by their secondnumber; sumswith the same first two numbers must be sorted by their third number; andso on. Within eachtest case, all sums must be distinct; the same sum cannot appear twice.

 

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

 

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25


注意三点:

(1)、用初始i=mark,来保证结果的顺序。

(2)、在递归每一层上,通过num[i]!=num[i-1]来保证没有重复值。最后保证没有重复结果。每一层的num[mark]为第一个数,自然可以入选。

(3)、DFS最后结果是从根节点开始到叶子节点结束的一条路径。而每一层上的值代表最后结果同一位置所有可能的取值。

#include<iostream>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)
{
    return a>b;
}
int t,n;
bool flag;
int num[13];
int result[13];
int length;
void dfs(int sum,int mark)
{
    if(sum==0)
    {
        flag=true;
        cout<<result[0];
        for(int i=1;i<length;i++)
        cout<<"+"<<result[i];
        cout<<endl;
        return;
    }
    if(sum<0||mark>=n) return;
    for(int i=mark;i<n;i++)                   
    {
        if(i==mark||num[i]!=num[i-1])  
        {                              
            result[length++]=num[i];
            dfs(sum-num[i],i+1);
            length--;
        }
    }
}
int main()
{
    while(cin>>t>>n)
    {
        if(n==0) break;
        cout<<"Sums of "<<t<<":"<<endl;
        for(int i=0;i<n;i++)
        cin>>num[i];
        flag=false;
        length=0;
        sort(num,num+n,cmp);
        dfs(t,0);
        if(flag==false) cout<<"NONE"<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值