Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6795 Accepted Submission(s): 3057
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
Source
Recommend
JGShining
#include<iostream>
#include<cstring>
using namespace std;
int vis[100],n;
int num[100];
int prime[40]={0,0,1,1,0,1,
0,1,0,0,0,
1,0,1,0,0,
0,1,0,1,0,
0,0,1,0,0,
0,0,0,1,0,
1,0,0,0,0,
0,1,0,1};
void dfs(int cur)
{
int i,j;
if(cur==n)
{
if(prime[1+num[n-1]])
{
cout<<"1";
for(i=1;i<n;i++)
cout<<" "<<num[i];
cout<<endl;
}
}
else
for(j=2;j<=n;j++)
{
if(!vis[j]&&prime[j+num[cur-1]])
{
vis[j]=1;
num[cur]=j;
dfs(cur+1);
vis[j]=0;
}
}/*if(cur%2==1)参照别人的代码,奇偶减枝
{
for(int t=2;t<=n;t+=2)
{
if(!vis[t]&&prime[t+num[cur-1]])
{
vis[t]=1;
num[cur]=t;
dfs(cur+1);
vis[t]=0;
}
}
} else if(cur%2==0)
{
for(int t=3;t<=n;t+=2)
{
if(!vis[t]&&prime[t+num[cur-1]])
{
vis[t]=1;
num[cur]=t;
dfs(cur+1);
vis[t]=0;
}
}
}*/
}
int main()
{
int l=1;
num[0]=1;//刚开始这个没写,一直没结果
while(cin>>n)
{
if(n%2==1) continue;
cout<<"Case "<<l++<<":"<<endl;
memset(vis,0,sizeof(vis));
dfs(1);
cout<<endl;
}
return 0;
}
#include<cstring>
using namespace std;
int vis[100],n;
int num[100];
int prime[40]={0,0,1,1,0,1,
0,1,0,0,0,
1,0,1,0,0,
0,1,0,1,0,
0,0,1,0,0,
0,0,0,1,0,
1,0,0,0,0,
0,1,0,1};
void dfs(int cur)
{
int i,j;
if(cur==n)
{
if(prime[1+num[n-1]])
{
cout<<"1";
for(i=1;i<n;i++)
cout<<" "<<num[i];
cout<<endl;
}
}
else
for(j=2;j<=n;j++)
{
if(!vis[j]&&prime[j+num[cur-1]])
{
vis[j]=1;
num[cur]=j;
dfs(cur+1);
vis[j]=0;
}
}/*if(cur%2==1)参照别人的代码,奇偶减枝
{
for(int t=2;t<=n;t+=2)
{
if(!vis[t]&&prime[t+num[cur-1]])
{
vis[t]=1;
num[cur]=t;
dfs(cur+1);
vis[t]=0;
}
}
} else if(cur%2==0)
{
for(int t=3;t<=n;t+=2)
{
if(!vis[t]&&prime[t+num[cur-1]])
{
vis[t]=1;
num[cur]=t;
dfs(cur+1);
vis[t]=0;
}
}
}*/
}
int main()
{
int l=1;
num[0]=1;//刚开始这个没写,一直没结果
while(cin>>n)
{
if(n%2==1) continue;
cout<<"Case "<<l++<<":"<<endl;
memset(vis,0,sizeof(vis));
dfs(1);
cout<<endl;
}
return 0;
}