深搜与不重复组合

zoj  1711

Sum It Up

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.


Input

The input file will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.


Output

For each test case, first output a line containing `Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.


Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0


Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

题意:给出最多 12 个数,让你任意选择其中若干数,要求其和为 t 的序列,

这题就是组合数学里的不重复组合,

不重复组合 

 就是这种组合的模型。。。。。。
输入 n 个数,求这 n 个数构成的集合的所有子集,不允许输出重复的项。 
输入样例 

1 1 3 
输出样例 

1 1 
1 1 3 
1 3 


Accepted1711C++0188
我的代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stdio.h>
#define MAX_N 10
int n, m,t;       //输入 n 个数,其中本质不同的有 m 个
int rcd[MAX_N]; //记录每个位置填的数
int used[MAX_N];//标记 m 个数可以使用的次数
int num[MAX_N]; //存放输入中本质不同的 m 个数
bool flag;
void unrepeat_combination(int l, int p,int ans){
 int i;
 if(ans==t)
 {
     flag=1;
     printf("%d", rcd[0]);
     for (i=1; i<l; i++)
     {
    printf("+%d", rcd[i]);
     }
    printf("\n");
    return;


 }
 else
 if(ans>t)
 return;
 for (i=p; i<m; i++)  //循环依旧从 p 开始,枚举剩下的本质不同
if(used[i] > 0){//若还可以用, 则可用次数减
 used[i]--;
 rcd[l] = num[i];   //在 l 位置放上该
unrepeat_combination(l+1, i,ans+num[i]); //填下一个位置
 used[i]++; //可用次数恢复
 }
}
int main(){
 int i, j, val;
 while(scanf("%d%d",&t,&n),t&&n)
 {
     flag=0;
     m = 0;
 for (i=0; i<n; i++){
 scanf("%d", &val);
 for (j=0; j<m; j++)
 if (num[j] == val){
 used[j]++; break;
 }
 if (j == m){
 num[m] = val; used[m++] = 1;
 }
 }
 printf("Sums of %d:\n",t);
 unrepeat_combination(0,0,0);
 if(flag==0)
 printf("NONE\n");
 }


 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值