洛谷1596 Lake Counting S 【搜索】

[USACO10OCT] Lake Counting S

题面翻译

由于近期的降雨,雨水汇集在农民约翰的田地不同的地方。我们用一个 N × M ( 1 ≤ N ≤ 100 , 1 ≤ M ≤ 100 ) N\times M(1\leq N\leq 100, 1\leq M\leq 100) N×M(1N100,1M100) 的网格图表示。每个网格中有水(W) 或是旱地(.)。一个网格与其周围的八个网格相连,而一组相连的网格视为一个水坑。约翰想弄清楚他的田地已经形成了多少水坑。给出约翰田地的示意图,确定当中有多少水坑。

输入第 1 1 1 行:两个空格隔开的整数: N N N M M M

2 2 2 行到第 N + 1 N+1 N+1 行:每行 M M M 个字符,每个字符是 W.,它们表示网格图中的一排。字符之间没有空格。

输出一行,表示水坑的数量。

题目描述

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John’s field, determine how many ponds he has.

输入格式

Line 1: Two space-separated integers: N and M * Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

输出格式

Line 1: The number of ponds in Farmer John’s field.

样例 #1

样例输入 #1

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

样例输出 #1

3

提示

OUTPUT DETAILS: There are three ponds: one in the upper left, one in the lower left, and one along the right side.
先贴一个bfs的模板

#include<iostream>
#include<cstdio>
using namespace std;
const int N=110;
const int flag[8][2]={{0,1},{0,-1},{1,0},{-1,0},{-1,-1},{-1,1},{1,-1},{1,1}};
char c[N][N];
int a[N][N],queue[N*N][2];
int n,m,ans;
bool p[N][N];
void bfs(int x,int y)
{
	int front=0,rear=2;
	queue[1][0]=x,queue[1][1]=y;
	while(front<rear-1)
	{
		++front;
		x=queue[front][0];
		y=queue[front][1];
		for(int i=0;i<8;++i)
		{
			int x1=x+flag[i][0];
			int y1=y+flag[i][1];
			if(x1<1||x1>n||y1<1||y1>n||!a[x1][y1]||p[x1][y1]) continue;
			p[x1][y1]=true;
			queue[rear][0]=x1;
			queue[rear++][1]=y1;
		}
	}
 } 
 int main()
 {
 	cin>>n>>m;
 	for(int i=1;i<=n;++i)
 		for(int j=1;j<=m;++j)
		{
			scanf(" %c",&c[i][j]);
			if(c[i][j]=='W') a[i][j]=1;			
		 } 
	

		
		
 	for(int i=1;i<=n;++i)
 		for(int j=1;j<=m;++j)
 			if(a[i][j] && !p[i][j])
 			{
 				++ans;
 				bfs(i,j);
			 }
	cout<<ans<<endl;
	return 0;
 }

再贴一个dfs的

#include<cstdio>
#include<cstring>
const int maxn=105;
char pic[maxn][maxn];
int m,n,idx[maxn][maxn];
void dfs(int r,int c,int id)
{
	if(r<0||r>=m||c<0||c>=n) return;
	if(idx[r][c]>0 || pic[r][c]!='W') return;
	idx[r][c]=id;
	for(int dr=-1;dr<=1;++dr)
		for(int dc=-1;dc<=1;++dc)
			if(dr!=0||dc!=0) dfs(r+dr,c+dc,id);
}
int main()
{
	while(scanf("%d%d",&m,&n)==2 && m && n)
	{
		for(int i=0;i<m;++i) scanf("%s",pic[i]);
		memset(idx,0,sizeof(idx));
		int cnt=0;
		for(int i=0;i<m;++i)
			for(int j=0;j<n;++j)
				if(idx[i][j]==0 && pic[i][j]=='W') dfs(i,j,++cnt);
		printf("%d\n",cnt);
	}
	return 0;
}
  • 22
    点赞
  • 23
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值