1034

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4629    Accepted Submission(s): 2832


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy. 
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 

Sample Input
  
  
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 

Sample Output
  
  
15 14 17 22 4 8



    就是跟着题意模拟就是了,我这里使用变量a记录上一个小孩给的糖果个数。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

#define MAXN 100010

using namespace std;

int n;
int kkke[MAXN];

bool not_equal()
{
	for(int i=1;i<n;i++)
	    if(kkke[i]!=kkke[0])
	        return true;
	return false;
}

int main()
{
	freopen("input.txt","r",stdin);
	freopen("output.txt","w",stdout);
	while(scanf("%d",&n),n)
	{
		int a,b,cnt=0;
		for(int i=0;i<n;i++)scanf("%d",&kkke[i]);
		while(not_equal())
		{
			cnt++;
			kkke[0]>>=1;
			a=kkke[0];
			for(int i=1;i<n;i++)
			{
				b=kkke[i]>>1;
				kkke[i]=a+b;
				if(kkke[i]&1)kkke[i]++;
				a=b;
			}
			kkke[0]+=a;
			if(kkke[0]&1)kkke[0]++;
		}
		printf("%d %d\n",cnt,kkke[0]);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值