Eight
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 18728 Accepted Submission(s): 5058
Special Judge
Problem Description
The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.
Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).
In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 x
where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4 5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8 9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12 13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x r-> d-> r->
The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.
Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).
In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle
1 2 3
x 4 6
7 5 8
is described by this list:
1 2 3 x 4 6 7 5 8
1 2 3
x 4 6
7 5 8
is described by this list:
1 2 3 x 4 6 7 5 8
Output
You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
Sample Input
2 3 4 1 5 x 7 6 8
Sample Output
ullddrurdllurdruldr
八数码问题,询问很多次,但终态是相同的,所以可以一开始逆向BFS求出所有答案(其实就是打表)。
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
const int fact[]={1,1,2,6,24,120,720,5040,40320,362880};
const int mv[4]={-3,-1,3,1};
const char *const dir="drul";
char hehe[362880];
int path[362880];
struct theStep{
int kkke[9];
int x;
int cnt;
bool operator==(const theStep &a)const
{
for(int i=0;i<9;i++)
if(kkke[i]!=a.kkke[i])
return false;
return true;
}
bool moveto(theStep &a,int b)
{
if(x+b<0||x+b>=9||(abs(b)==1&&x/3!=(x+b)/3))return false;
for(int i=0;i<9;i++)a.kkke[i]=kkke[i];
swap(a.kkke[x],a.kkke[x+b]);
a.x=x+b;
a.cnt=cnt+1;
return true;
}
int getValue()
{
int value=0;
for(int i=1;i<9;i++)
for(int j=0;j<i;j++)
if(kkke[i]>kkke[j])
value+=fact[i];
return value;
}
}S,T,nows,nexts;
int SValue;
queue<theStep>q;
void init()
{
for(int i=0;i<8;i++)S.kkke[i]=i+1;
S.kkke[8]=0;
S.cnt=0;
S.x=8;
SValue=S.getValue();
q.push(S);
hehe[SValue]='l';
while(!q.empty())
{
nows=q.front();q.pop();
int nowValue=nows.getValue();
for(int i=0;i<4;i++)
{
if(nows.moveto(nexts,mv[i]))
{
int nextValue=nexts.getValue();
if(hehe[nextValue])continue;
q.push(nexts);
hehe[nextValue]=dir[i];
path[nextValue]=nowValue;
}
}
}
}
int main()
{
freopen("input.txt","r",stdin);
freopen("output.txt","w",stdout);
init();
int a[10];
while(scanf("%s",a)==1)
{
if(a[0]=='x')T.kkke[0]=0;
else T.kkke[0]=a[0]-'0';
for(int i=1;i<9;i++)
{
scanf("%s",a);
if(a[0]=='x')T.kkke[i]=0;
else T.kkke[i]=a[0]-'0';
}
if(S==T)printf("lr\n");
else
{
int nowv=T.getValue();
if(hehe[nowv])
{
do{
putchar(hehe[nowv]);
nowv=path[nowv];
}while(nowv!=SValue);
putchar('\n');
}
else printf("unsolvable\n");
}
}
return 0;
}